summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2019-08-04 21:56:36 +0300
committerMaxim Koltsov <maksbotan@gentoo.org>2019-08-04 22:11:58 +0300
commit8c4c249ee789dcb7e309b2de845d60edc18a5fe1 (patch)
tree5dc4fb2615d31c2e01baea2cdb58c9615f20fdeb /x11-plugins/vicious/vicious-2.3.3.ebuild
parentx11-plugins/vicious: remove old (diff)
downloadgentoo-8c4c249ee789dcb7e309b2de845d60edc18a5fe1.tar.gz
gentoo-8c4c249ee789dcb7e309b2de845d60edc18a5fe1.tar.bz2
gentoo-8c4c249ee789dcb7e309b2de845d60edc18a5fe1.zip
x11-plugins/vicious: bump to 2.3.3
Package-Manager: Portage-2.3.67, Repoman-2.3.12 Signed-off-by: Maxim Koltsov <maksbotan@gentoo.org>
Diffstat (limited to 'x11-plugins/vicious/vicious-2.3.3.ebuild')
-rw-r--r--x11-plugins/vicious/vicious-2.3.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/vicious/vicious-2.3.3.ebuild b/x11-plugins/vicious/vicious-2.3.3.ebuild
new file mode 100644
index 000000000000..4934c0636f0d
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.3.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/Mic92/vicious"
+SRC_URI="https://github.com/Mic92/vicious/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="contrib"
+
+DEPEND=""
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets helpers.lua init.lua
+ dodoc Changes.md README.md TODO
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ newdoc contrib/README.md README.contrib
+ fi
+}