summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/screenlets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/screenlets')
-rw-r--r--x11-plugins/screenlets/Manifest1
-rw-r--r--x11-plugins/screenlets/metadata.xml23
-rw-r--r--x11-plugins/screenlets/screenlets-0.1.6.ebuild62
3 files changed, 86 insertions, 0 deletions
diff --git a/x11-plugins/screenlets/Manifest b/x11-plugins/screenlets/Manifest
new file mode 100644
index 000000000000..abce77cc6f72
--- /dev/null
+++ b/x11-plugins/screenlets/Manifest
@@ -0,0 +1 @@
+DIST screenlets-0.1.6.tar.bz2 814470 SHA256 65383faaf02b6d571d2136c849cec5885583f513a9bbffacd3381cd998ee86e3 SHA512 f7b38de88ca500bef49a1be327aae29bb2c784e63b3ba0f7b02ed8d235935e0d372e7c1cf55e8ecff9bc91cb88fb2a697d70d18812ff06ff63935aca1612cb15 WHIRLPOOL cf3a25476323d433b03414f210afa7c384738b29167694d2c938c9fbe285d25e392679f348232758cc17a1e95af75dc90ee8a77d859d8452890fc77250c1fd69
diff --git a/x11-plugins/screenlets/metadata.xml b/x11-plugins/screenlets/metadata.xml
new file mode 100644
index 000000000000..81b409cbd36f
--- /dev/null
+++ b/x11-plugins/screenlets/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <longdescription lang="en">
+ Screenlets are small owner-drawn applications (written in Python) that
+ can be described as "the virtual representation of things lying/standing
+ around on your desk". Sticknotes, clocks, rulers, ... the possibilities
+ are endless.
+
+ The goal of the Screenlets base-classes is to simplify the creation of
+ fully themeable mini-apps that each solve basic desktop-work-related
+ needs and generally improve the usability and eye-candy of the modern
+ composited Linux-desktop.
+ </longdescription>
+ <use>
+ <flag name="svg">Highly Recommended: Enable SVG graphics via
+ <pkg>dev-python/librsvg-python</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">screenlets</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/screenlets/screenlets-0.1.6.ebuild b/x11-plugins/screenlets/screenlets-0.1.6.ebuild
new file mode 100644
index 000000000000..70842062b243
--- /dev/null
+++ b/x11-plugins/screenlets/screenlets-0.1.6.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=yes
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Screenlets are small owner-drawn applications"
+HOMEPAGE="http://www.screenlets.org https://launchpad.net/screenlets"
+SRC_URI="http://code.launchpad.net/screenlets/trunk/${PV}/+download/screenlets-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+svg"
+
+RDEPEND="
+ dev-python/beautifulsoup:python-2
+ dev-python/dbus-python
+ dev-python/gconf-python
+ dev-python/gnome-keyring-python
+ dev-python/libwnck-python
+ dev-python/pyxdg
+ svg? ( dev-python/librsvg-python )
+ x11-libs/libnotify
+ x11-misc/xdg-utils
+"
+
+src_prepare() {
+ # this is tricky because screenlets translations do not always have -manager
+ # translations and vice versa, which is also why we do not die() on rm fail
+ strip-linguas -u ${PN}/ ${PN}-manager/
+ local lingua pofile
+ for pofile in ${PN}/*.po ${PN}-manager/*.po; do
+ lingua=${pofile/$PN*\/}
+ lingua=${lingua/.po}
+
+ if ! has ${lingua} ${LINGUAS}; then
+ rm -f ${PN}/${lingua}.po
+ rm -f ${PN}-manager/${lingua}.po
+ fi
+ done
+
+ distutils-r1_src_prepare
+ python_fix_shebang src/
+ sed -i $(find src/ -type f) -e 's|exec python|&2|g;s|python -u|python2 -u|g' || die
+ sed -i desktop-menu/screenlets-{daemon,manager}.desktop -e 's|> .*||g' || die
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ insinto /usr/share/icons
+ doins desktop-menu/screenlets.svg
+
+ # Insert .desktop files
+ domenu desktop-menu/*.desktop
+}