summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2020-11-05 21:40:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-23 08:11:31 +0100
commitb2c74bafa5d7116ff3602071f5f9e3b4e130fd5f (patch)
tree9d070bce34a8e4ad73377f454bf558b77351cacc /x11-misc
parentx11-libs/libfm-qt: add version 0.16.0 (diff)
downloadgentoo-b2c74bafa5d7116ff3602071f5f9e3b4e130fd5f.tar.gz
gentoo-b2c74bafa5d7116ff3602071f5f9e3b4e130fd5f.tar.bz2
gentoo-b2c74bafa5d7116ff3602071f5f9e3b4e130fd5f.zip
x11-misc/pcmanfm-qt: add version 0.16.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pcmanfm-qt/Manifest1
-rw-r--r--x11-misc/pcmanfm-qt/pcmanfm-qt-0.16.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/pcmanfm-qt/Manifest b/x11-misc/pcmanfm-qt/Manifest
index d35400c998e8..ada3b61f3f61 100644
--- a/x11-misc/pcmanfm-qt/Manifest
+++ b/x11-misc/pcmanfm-qt/Manifest
@@ -1 +1,2 @@
DIST pcmanfm-qt-0.15.1.tar.xz 257832 BLAKE2B 78c8f5723b529b7f8a00870f017818183a498d8a1f68f8f24ab756eeda9b35d8d998b42d87f78e4a8fb6725bf3e812dca74bc1464f285a6a984dae1996b43f46 SHA512 db0d3cc683b5c94cabab5a8c68b3ae8bf5938735b34989a420692e933bb54d53ebb15da9af4a59039bfd101de0cc00c521c08207e81bfad9d80315e2d94bc559
+DIST pcmanfm-qt-0.16.0.tar.xz 275792 BLAKE2B 65deed6a6d942a57c6cdf497d254d5052b1bcca219198f3cbaa2bcd29048976610afcfc31cc2101f8ddad88f436bc8dba2483b8305ff55f178dd65c91a549814 SHA512 42c754267966b29722bd771d6f6f09c20cdb3b33bbe49deec982bdac98379dff92ac13f6f70b603aea963a3e1003034475cb682ec4264cfcf581c189826ea727
diff --git a/x11-misc/pcmanfm-qt/pcmanfm-qt-0.16.0.ebuild b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.16.0.ebuild
new file mode 100644
index 000000000000..db6ed8248064
--- /dev/null
+++ b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.16.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake optfeature xdg-utils
+
+DESCRIPTION="Qt GUI Tabbed Filemanager"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.8.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+ x11-libs/libxcb:=
+ x11-misc/xdg-utils
+ virtual/eject
+ virtual/freedesktop-icon-theme
+"
+RDEPEND="${DEPEND}
+ !lxqt-base/lxqt-l10n
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ optfeature "mount password storing" gnome-base/gnome-keyring
+ ! has_version lxqt-base/lxqt-meta && optfeature "trash functionality" gnome-base/gvfs
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}