summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-04 15:50:59 +0100
committerSam James <sam@gentoo.org>2023-10-04 16:10:44 +0100
commit14a99c5debae88a163d657ec2ffe65d19202bba7 (patch)
tree7301f7621adc0e1f02485b657a01ceb4bb8f91c4 /x11-misc
parentmedia-libs/svt-hevc: don't redefine _FORTIFY_SOURCE (diff)
downloadgentoo-14a99c5debae88a163d657ec2ffe65d19202bba7.tar.gz
gentoo-14a99c5debae88a163d657ec2ffe65d19202bba7.tar.bz2
gentoo-14a99c5debae88a163d657ec2ffe65d19202bba7.zip
x11-misc/cairo-clock: don't redefine _FORTIFY_SOURCE
Closes: https://bugs.gentoo.org/898240 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.4-r3.ebuild49
-rw-r--r--x11-misc/cairo-clock/files/cairo-clock-0.3.4-fortify-source.patch16
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.4-r3.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.4-r3.ebuild
new file mode 100644
index 000000000000..fa63e6bff82c
--- /dev/null
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.4-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="An analog clock displaying the system-time"
+HOMEPAGE="https://launchpad.net/cairo-clock"
+SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.8
+ >=gnome-base/libglade-2.6
+ >=gnome-base/librsvg-2.14
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/pango-1.10
+"
+DEPEND="${RDEPEND}"
+# autoconf-archive for F_S patch
+BDEPEND="
+ dev-util/intltool
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-desktop.patch
+ "${FILESDIR}"/${P}-linker.patch
+ "${FILESDIR}"/${P}-fortify-source.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ gzip -d "${ED}"/usr/share/man/man1/cairo-clock.1.gz || die
+}
diff --git a/x11-misc/cairo-clock/files/cairo-clock-0.3.4-fortify-source.patch b/x11-misc/cairo-clock/files/cairo-clock-0.3.4-fortify-source.patch
new file mode 100644
index 000000000000..c10461b47f35
--- /dev/null
+++ b/x11-misc/cairo-clock/files/cairo-clock-0.3.4-fortify-source.patch
@@ -0,0 +1,16 @@
+Don't clobber our toolchain defaults.
+
+https://bugs.gentoo.org/898240
+--- a/configure.ac
++++ b/configure.ac
+@@ -96,7 +96,9 @@ CLOCK_DEFINES='-DDATA_DIR="\"$(datadir)\"" -DPKGDATA_DIR="\"$(pkgdatadir)\""'
+ AC_SUBST([CLOCK_DEFINES])
+
+ dnl CFLAGS
+-CFLAGS="$CFLAGS -Wall -pedantic -std=c99 -fno-strict-aliasing -fmessage-length=0 -D_FORTIFY_SOURCE=2"
++CFLAGS="$CFLAGS -Wall -pedantic -std=c99 -fno-strict-aliasing -fmessage-length=0"
++
++AX_ADD_FORTIFY_SOURCE
+
+ AC_CONFIG_FILES([
+ Makefile