summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-02-13 13:40:15 -0500
committerMatt Turner <mattst88@gentoo.org>2024-02-13 14:37:56 -0500
commit90abba7ddc277aba54718f63df9f5147b89d1b04 (patch)
tree202db0aaf5b378f960afb9cd43d2ea1ece2edb19 /x11-libs
parentdev-libs/libei: Version bump to 1.2.1 (diff)
downloadgentoo-90abba7ddc277aba54718f63df9f5147b89d1b04.tar.gz
gentoo-90abba7ddc277aba54718f63df9f5147b89d1b04.tar.bz2
gentoo-90abba7ddc277aba54718f63df9f5147b89d1b04.zip
x11-libs/libXext: Version bump to 1.3.6
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXext/Manifest1
-rw-r--r--x11-libs/libXext/libXext-1.3.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/libXext/Manifest b/x11-libs/libXext/Manifest
index 49c650517173..8a5a927cddbd 100644
--- a/x11-libs/libXext/Manifest
+++ b/x11-libs/libXext/Manifest
@@ -1 +1,2 @@
DIST libXext-1.3.5.tar.xz 340108 BLAKE2B 0041ef38ba363ff82105f4e626851d2ef7db35804ca80de84e5ed99d97b4f5dd9877b9a43f8690d9040fadc7ee075fca640752bcdde4f7be0e220c1a5e0058e8 SHA512 fd9805982dabfb14b1526c0cb71f94508003fa3fcd60560d387465afd891c1dca61927ae86278436d53f4b840cacd1f412071fdc3dce1d6f730610a9c163d59b
+DIST libXext-1.3.6.tar.xz 341092 BLAKE2B 9879ba01e45fb84613c62b161334bdb49e0cd9a5ca6c33d27a4add2a94c4bae700cc8021e383493cc1eec31da4969f99461dcb1a2aa0613cb300ceaefd3a3b7e SHA512 fd7693b5698cc4f5e80002a2cd4bd88e5d52c755c19a0417ee73029bd65f9d77b0969e765a1febc4d8fce1ba5dfb7278717f47be742e33d8fc5eb941e769792e
diff --git a/x11-libs/libXext/libXext-1.3.6.ebuild b/x11-libs/libXext/libXext-1.3.6.ebuild
new file mode 100644
index 000000000000..ac2ddf68da3f
--- /dev/null
+++ b/x11-libs/libXext/libXext-1.3.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xext library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND=">=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}