summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-06-17 08:24:12 -0500
committerKacper Kowalik <xarthisius@gentoo.org>2016-06-17 08:24:12 -0500
commit1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73 (patch)
treed1d6a88f592437a34990712e7a0e9b73002eb3cd /x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild
parentdev-libs/libsodium: Add IUSE="cpu_flags_x86_sse4_1 cpu_flags_x86_aes" (diff)
downloadgentoo-1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73.tar.gz
gentoo-1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73.tar.bz2
gentoo-1f5c3d5f3bb9d01b6c49a4f6dfc9288c6c3caf73.zip
x11-libs/xcb-util-xrm: Initial import, fixes #579650
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild')
-rw-r--r--x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild
new file mode 100644
index 000000000000..f141ce6ff082
--- /dev/null
+++ b/x11-libs/xcb-util-xrm/xcb-util-xrm-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_BASE_INDIVIDUAL_URI=""
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="http://xcb.freedesktop.org/"
+SRC_URI="https://github.com/Airblader/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( x11-libs/libX11[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ xorg-2_src_configure
+}