summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-17 19:06:38 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-17 19:07:28 -0800
commit91f3b8ac017190caf1fe6148bc1092e8bbca0ae5 (patch)
treec8856e3e9cb0d1f59e75cb2b82fb90368ddb973b /x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
parentdev-libs/libinput: Version bump to 1.5.4. (diff)
downloadgentoo-91f3b8ac017190caf1fe6148bc1092e8bbca0ae5.tar.gz
gentoo-91f3b8ac017190caf1fe6148bc1092e8bbca0ae5.tar.bz2
gentoo-91f3b8ac017190caf1fe6148bc1092e8bbca0ae5.zip
x11-drivers/xf86-input-wacom: Version bump to 0.34.0.
Diffstat (limited to 'x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
new file mode 100644
index 000000000000..5a0aed8aaae2
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.34.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://git.code.sf.net/p/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+# depend on libwacom for its udev rules, bug #389633
+RDEPEND="dev-libs/libwacom
+ virtual/udev
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}