summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-03-21 18:23:16 -0400
committerAaron Bauman <bman@gentoo.org>2019-03-21 18:23:56 -0400
commit7de462fe77d5b1cd89a31efebcd71d4a0f697682 (patch)
treea1baf86e70a74b626378e2c032070e6081f836c3 /www-servers
parentnet-fs/mc: Version bump (diff)
downloadgentoo-7de462fe77d5b1cd89a31efebcd71d4a0f697682.tar.gz
gentoo-7de462fe77d5b1cd89a31efebcd71d4a0f697682.tar.bz2
gentoo-7de462fe77d5b1cd89a31efebcd71d4a0f697682.zip
www-servers/gunicorn: drop vulnerable wrt bug #653590
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/gunicorn/Manifest4
-rw-r--r--www-servers/gunicorn/gunicorn-19.1.1.ebuild51
-rw-r--r--www-servers/gunicorn/gunicorn-19.3.0.ebuild52
-rw-r--r--www-servers/gunicorn/gunicorn-19.4.5.ebuild49
-rw-r--r--www-servers/gunicorn/gunicorn-19.6.0.ebuild50
5 files changed, 0 insertions, 206 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index 0e8db8333182..771b3c6ad438 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1,5 +1 @@
-DIST gunicorn-19.1.1.tar.gz 385155 BLAKE2B 683bff89e9f7037b22748c968f842cbd6328f63aaf63edba088bdf5cb1b4774614a8bfba1449bc0c90685ba2a12cc95b474d15dfd40f0f22055d1e9d554fc55c SHA512 1b42f0dadb8ced12954e821ad3dc7fad67ae6f1123218fe79e32d7089d9ae65bcd973613c226d9a16b11d7d35632990f2c9499594c7a383a79698a1c2db471de
-DIST gunicorn-19.3.0.tar.gz 395381 BLAKE2B cbdf0e4a8c5f107b3dbee9ac30b141142bd10e5a4d9046de3c2fe3af965e6b5f091ff29bdfd9f4a1da75ea409e6f9a3b9627f6069d5529dc9db4d6ad1e3f9860 SHA512 8c4e0bb1bf0b35aaf9160b9b7d87890a991451fbc86186454203f3483767858944704c1ec22dd52480ce1e4693e84b62b1428dd3b67b2ae925e0475dc08fcb50
-DIST gunicorn-19.4.5.tar.gz 399066 BLAKE2B 046dd95170b3d6c6071c955462af5777ee0fbaa48d80c4a16b78fb1c9abd49bef98f7428e7f861b404a2791683074ae37a22a7e73d5b7f183fa6ac77d139123e SHA512 a255178a4ce7966af5883fc6c104e7c472c87ce91861caf976b52cfb0ccd90b34109130334afa6c1f6dd251a4b33b052b1f9a4f598c5cd1e7f26e332b92e9154
-DIST gunicorn-19.6.0.tar.gz 404497 BLAKE2B 8edc6907daf9cced83ab4213146d468789a23b4428a562f9f5cc7d2aa8f7c57137ca9f163609b6a8955537dfc5a93910a7cef183fa6457c5017cbb3941f4e0c8 SHA512 50b69ae18acc6f60be6fc5c6f4a867d8415d32009a1f959155b58502d52403a057612e97d6c9b69ec068ee5af7b9b045952a636a5edf4713a1249492611be479
DIST gunicorn-19.8.1.tar.gz 415541 BLAKE2B f0eefc4ff24052320b4dfaac3fc2523487f8dbb63365a9a3c52bc411b4d8f6150f348c709cae94dc4acb45e7fda534cf462d0339abc0325230d3560f76ce3241 SHA512 7f7fcbcde20b70d3a2faad595e08a028530348895f784eddcb35f24b3d5a7955edfc5b68aac4630243798fa37d41b7e869ec0d454dc80700c2630ba2cc39afc0
diff --git a/www-servers/gunicorn/gunicorn-19.1.1.ebuild b/www-servers/gunicorn/gunicorn-19.1.1.ebuild
deleted file mode 100644
index 65b519308c98..000000000000
--- a/www-servers/gunicorn/gunicorn-19.1.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="doc examples test"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-DOCS="README.rst"
-
-python_prepare() {
- # these tests requires an already installed version of gunicorn
- rm tests/test_003-config.py
-
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-
- if use examples; then
- insinto /usr/share/doc/${P}
- doins -r examples
- fi
-}
diff --git a/www-servers/gunicorn/gunicorn-19.3.0.ebuild b/www-servers/gunicorn/gunicorn-19.3.0.ebuild
deleted file mode 100644
index 133e77bef3ad..000000000000
--- a/www-servers/gunicorn/gunicorn-19.3.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn/ https://github.com/benoitc/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS="README.rst"
-
-python_prepare_all() {
- # these tests requires an already installed version of gunicorn
- rm tests/test_003-config.py || die
-
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}
diff --git a/www-servers/gunicorn/gunicorn-19.4.5.ebuild b/www-servers/gunicorn/gunicorn-19.4.5.ebuild
deleted file mode 100644
index e926a618c442..000000000000
--- a/www-servers/gunicorn/gunicorn-19.4.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn/ https://github.com/benoitc/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-DOCS="README.rst"
-
-python_prepare_all() {
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}
diff --git a/www-servers/gunicorn/gunicorn-19.6.0.ebuild b/www-servers/gunicorn/gunicorn-19.6.0.ebuild
deleted file mode 100644
index 895e2e4d9c49..000000000000
--- a/www-servers/gunicorn/gunicorn-19.6.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="A WSGI HTTP Server for UNIX"
-HOMEPAGE="http://gunicorn.org https://pypi.org/project/gunicorn/ https://github.com/benoitc/gunicorn"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT PSF-2 doc? ( BSD )"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc examples test"
-
-RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-DOCS="README.rst"
-
-python_prepare_all() {
- sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- py.test -v || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}