summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2023-12-30 17:46:43 -0500
committerRick Farina <zerochaos@gentoo.org>2023-12-30 17:50:21 -0500
commitf942a1d8a226113608a0b81cf1d6853dc7fe0735 (patch)
tree2e48b627eb0ce63f39c2c7a3b1afb7584603d961 /www-apps/novnc
parentwww-apps/novnc: PEP517 build (diff)
downloadgentoo-f942a1d8a226113608a0b81cf1d6853dc7fe0735.tar.gz
gentoo-f942a1d8a226113608a0b81cf1d6853dc7fe0735.tar.bz2
gentoo-f942a1d8a226113608a0b81cf1d6853dc7fe0735.zip
www-apps/novnc: add 1.3.0
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'www-apps/novnc')
-rw-r--r--www-apps/novnc/Manifest1
-rw-r--r--www-apps/novnc/novnc-1.3.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/www-apps/novnc/Manifest b/www-apps/novnc/Manifest
index ac5edf9e0023..8fe93b808ea2 100644
--- a/www-apps/novnc/Manifest
+++ b/www-apps/novnc/Manifest
@@ -1 +1,2 @@
DIST novnc-1.2.0.tar.gz 1356408 BLAKE2B a84b767afcdaa641a21943d19ac93c9200074c24c83c899fe2452a82eef526ecd74de92da47b3caa85abe9d51f2fb8d5078f3bf66c0868a241218d22a9088239 SHA512 461490da7bb983e9c94b8ce39f8455ee6609b5a9df8d88254bcc37ebaa5153f5ee9db6afbd88b51762d6d55661bc5cde6fbe70616597583bfce1203e337adf75
+DIST novnc-1.3.0.tar.gz 661659 BLAKE2B 9e2f42ccf7cdac74017cf7d91538279de6a9451b0e3da8ef4ef2cc55b7fafa83be5fccb0ee314c887ddc35d5c3f54f51a93148b25517838f0f8aab7bdc4fd008 SHA512 2c9eb019bd9c86a0ffb716eba06e8f05bc522c37561e0acc7f88a66188c617ebc54f4cc9220897c241280ba2ed5919a2050a94eeb3da2c030bde43af0bd92c51
diff --git a/www-apps/novnc/novnc-1.3.0.ebuild b/www-apps/novnc/novnc-1.3.0.ebuild
new file mode 100644
index 000000000000..ff11d98a0fd9
--- /dev/null
+++ b/www-apps/novnc/novnc-1.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=no
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="noVNC is a VNC client implemented using HTML5 technologies"
+HOMEPAGE="https://novnc.com/info.html"
+
+if [[ ${PV} == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/novnc/noVNC"
+else
+ SRC_URI="https://github.com/novnc/noVNC/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/noVNC-${PV}"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-python/websockify[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]"
+
+python_compile() {
+ :
+}
+
+src_install() {
+ exeinto /usr/share/novnc/utils
+ for f in utils/*; do
+ [[ ! f = utils/README.md ]] && doexe $f
+ done
+
+ dodoc README.md LICENSE.txt
+
+ insinto /usr/share/novnc
+ doins -r vnc.html vnc_lite.html app/ core/ vendor/
+ dosym vnc_lite.html /usr/share/novnc/vnc_auto.html # for compat
+ dosym ../share/novnc/utils/novnc_proxy /usr/bin/novnc
+}