summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-09-21 16:01:04 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-09-21 16:01:33 +0300
commit7cfa015b36464a3d01e412b8f1902fac74c2ef4a (patch)
tree07bf8cd40b88d2dfddebff05b58f6946d75e3b56 /www-apps/drupal
parentwww-apps/drupal: drop 9.5.8 (diff)
downloadgentoo-7cfa015b36464a3d01e412b8f1902fac74c2ef4a.tar.gz
gentoo-7cfa015b36464a3d01e412b8f1902fac74c2ef4a.tar.bz2
gentoo-7cfa015b36464a3d01e412b8f1902fac74c2ef4a.zip
www-apps/drupal: add 10.0.11
Security update. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-10.0.11.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index da654e05f548..f4d8cd050e10 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,4 @@
+DIST drupal-10.0.11.tar.gz 17461226 BLAKE2B cb0002fb00447923f84202e0e4703eba5bb82c89fb349b015da1ce98cc85b223fdad88c8ac19bae6c7488f23643465613708e78b83aeec127fa40035cd148e5a SHA512 574ed4d82ba31145add7e2bb18a9cbf19afa7c4d015468317747be2d438b0a4a75807669ba95c9593c2853e3cab44757741a54265da305f2df00a80626566e47
DIST drupal-10.0.8.tar.gz 17433029 BLAKE2B 8fbdb7ca86decea007ecd369f5f9c9c9a751ee56df9db5ce117be2cba8d3d82f09994344590be1d3ce690fa747d4a59cf3c04f7427ee531f322d0ecaab5a1a7a SHA512 e1fccce448019b3cfb3a08d0fdd6e6f3ff4ce5110c51393e5c99242e1250e25a647029e4c69600f0e52da8585ae2dcb53804de860fde952928e07b694a61a070
DIST drupal-7.97.tar.gz 3381082 BLAKE2B 3997305b91330db16843ee17927435b1bba4b080b72b36c1c90508e9edc0379f33aad3fae31fd637034d7ddeae425d75bd2252ed733ee00a6d9e12a75b909979 SHA512 2ea4ae63f9dc87043f3743f7e426c2fe940ca930a764c9eff0cb19e25fb3117599350c8fab92fc1bc45c2e6719ae20caba039180d63672cb1616f7526b798dcb
DIST drupal-9.5.11.tar.gz 22593304 BLAKE2B b978bed98649eb43999c414d11c1f168eca9800e65016e5e444799c9be75f6dd3914287e6845b9b9f698d3c0a3e368ac48f35b9b9cf989e23ad8f3abd70f028a SHA512 a8fe6756d4540c95af6d615d8eb2a063f79a502920d609db15ef07ede05727a933f5720e5ca64fe5d70c71d7d6971217633135675bb7f27db2130bbd01d8094d
diff --git a/www-apps/drupal/drupal-10.0.11.ebuild b/www-apps/drupal/drupal-10.0.11.ebuild
new file mode 100644
index 000000000000..6a27404d4a84
--- /dev/null
+++ b/www-apps/drupal/drupal-10.0.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+# upstream supports php 8.1+, but dev-php/pecl-uploadprogress does not have 8.2
+# limit php to 8.1 for now
+RDEPEND="
+ dev-lang/php:8.1[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress[php_targets_php8-1] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt \
+ core/USAGE.txt "
+
+ dodoc ${docs}
+ rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-10 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}