summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-01 22:46:43 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-12-19 17:12:32 -0800
commitfe28d1908e27e8bc4f7e01d673c4bfc7149f855b (patch)
treee32a2bdf6d04690fe1c53f62c118b110f9be3b08 /sys-process/numad/numad-9999.ebuild
parentmedia-libs/openjpeg: check against known architecture specific failures (diff)
downloadgentoo-fe28d1908e27e8bc4f7e01d673c4bfc7149f855b.tar.gz
gentoo-fe28d1908e27e8bc4f7e01d673c4bfc7149f855b.tar.bz2
gentoo-fe28d1908e27e8bc4f7e01d673c4bfc7149f855b.zip
sys-process/numad: add service files
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-process/numad/numad-9999.ebuild')
-rw-r--r--sys-process/numad/numad-9999.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
index d292669c500f..9b2cc2d66a7b 100644
--- a/sys-process/numad/numad-9999.ebuild
+++ b/sys-process/numad/numad-9999.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit linux-info toolchain-funcs
+inherit linux-info systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://pagure.io/numad.git"
inherit git-r3
else
- SRC_URI=""
- KEYWORDS="~amd64 ~x86 -arm -s390"
+ EGIT_COMMIT=""
+ SRC_URI="mirror://gentoo/numad-0.5-${EGIT_COMMIT:0:7}.tar.bz2"
+ KEYWORDS="~amd64 -arm ~arm64 -s390 ~x86"
+ S="${WORKDIR}/${PN}-${EGIT_COMMIT:0:7}"
fi
DESCRIPTION="The NUMA daemon that manages application locality"
@@ -33,4 +35,14 @@ src_compile() {
src_install() {
emake prefix="${ED}/usr" install
+
+ newinitd "${FILESDIR}/numad.initd" numad
+ newconfd "${FILESDIR}/numad.confd" numad
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/numad.logrotated" numad
+
+ insinto /etc
+ doins numad.conf
+ systemd_dounit numad.service
}