summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-01-03 21:56:33 +0000
committerSam James <sam@gentoo.org>2024-01-03 21:56:33 +0000
commit553b282b75beaf4c11a3018587bbb9ae613f43f8 (patch)
tree6e3b9ec2096a89f7691e936253904de8341a63e7 /sys-libs/glibc/glibc-9999.ebuild
parentkde-apps/dolphin: Disable kitemlistcontrollerexpandtest (diff)
downloadgentoo-553b282b75beaf4c11a3018587bbb9ae613f43f8.tar.gz
gentoo-553b282b75beaf4c11a3018587bbb9ae613f43f8.tar.bz2
gentoo-553b282b75beaf4c11a3018587bbb9ae613f43f8.zip
sys-libs/glibc: sync livc
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 72861bd7fa19..ed6513f68aee 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -88,6 +88,8 @@ fi
# * normal 'strip' command trims '.symtab'
# Thus our main goal here is to prevent 'libpthread.so.0' from
# losing it's '.symtab' entries.
+# - similarly, valgrind requires knowledge about symbols in ld.so:
+# bug #920753
# As Gentoo's strip does not allow us to pass less aggressive stripping
# options and does not check the machine target we strip selectively.
@@ -1348,6 +1350,8 @@ glibc_do_src_install() {
# gdb thread introspection relies on local libpthreads symbols. stripping breaks it
# See Note [Disable automatic stripping]
dostrip -x $(alt_libdir)/libpthread-${upstream_pv}.so
+ # valgrind requires knowledge about ld.so symbols.
+ dostrip -x $(alt_libdir)/ld-*.so*
if [[ -e ${ED}/$(alt_usrlibdir)/libm-${upstream_pv}.a ]] ; then
# Move versioned .a file out of libdir to evade portage QA checks