summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-11-16 16:55:58 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-11-16 16:55:58 -0500
commitbc4daf2825744020bcc5393c1da400f7e48785e4 (patch)
treeff9a3639a24d2bf4c69d43fb1e5a897e32780315 /sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild
parentsys-cluster/nova: updating liberty caps (diff)
downloadgentoo-bc4daf2825744020bcc5393c1da400f7e48785e4.tar.gz
gentoo-bc4daf2825744020bcc5393c1da400f7e48785e4.tar.bz2
gentoo-bc4daf2825744020bcc5393c1da400f7e48785e4.zip
sys-fs/f2fs-tools: version bump to 1.5.0, bug #565938
We add subslot SLOT="0/0" in anticipation of possible bumps to the SONAME in the future. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild
new file mode 100644
index 000000000000..7d8c8ba0fce8
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf --prefix=/ --includedir=/usr/include
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
+}