summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-30 02:19:48 +0000
committerSam James <sam@gentoo.org>2024-11-30 02:19:48 +0000
commit02fc58c7c363a44a3d8ba718935e83050fb26294 (patch)
tree5e5d0a4aff52a68d6c5f6c8dbc3ab6280d5d7166 /sys-devel
parentdev-debug/gdb: support for AMD GPU debugging via USE=rocm (diff)
downloadgentoo-02fc58c7c363a44a3d8ba718935e83050fb26294.tar.gz
gentoo-02fc58c7c363a44a3d8ba718935e83050fb26294.tar.bz2
gentoo-02fc58c7c363a44a3d8ba718935e83050fb26294.zip
sys-devel/crossdev: add 20241130
Michal Rostecki (4): crossdev: Use libunwind and libc++ in LLVM environments ci: Test crossdev in GitHub Actions ci: Run the container explicitly with `docker run` ci: Test more targets, move the testing logic to a script Sam James (4): crossdev: tweak GUSE_DISABLE* crossdev: no SSP for nvptx wrappers/emerge-wrapper: add nvptx* crossdev: nvptx target fixes Bug: https://bugs.gentoo.org/945296 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/Manifest1
-rw-r--r--sys-devel/crossdev/crossdev-20241130.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 376eaa0a4182..a0d2a37ac278 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1 +1,2 @@
DIST crossdev-20240921.tar.xz 31008 BLAKE2B 9daeabcbeefa32624d71b86c5ddeb1f6bf6ccdf4e6f590bf7517388d4d68b73ae2651ca09d122f128f002568127bd5d7d767db9d6c043e5330b62c3104929848 SHA512 6b7f0bce309d2b0a8fdf9b28cf72098de9dafaf7f338a8308e94e2068cefc15cd2407eee39a9eeb0ea0a1bc46569cedc69a51bb01f140faebe374b660cb1cdf6
+DIST crossdev-20241130.tar.xz 32832 BLAKE2B eaf14cf139abf73816f9facd090846c92d3056e34eb4d7f9bca2c2f4b22e9d3f342e93dac70b462b252b64eb86270f666d151170a6474961342a26f152919f69 SHA512 59054ba5015c18c9b80e2258391f667ad4585644009ab74b631557e8c6550270e188967515a13ab0dd8e27272c6e5f0650a77e8c100dadbc2686cd8796a62c00
diff --git a/sys-devel/crossdev/crossdev-20241130.ebuild b/sys-devel/crossdev/crossdev-20241130.ebuild
new file mode 100644
index 000000000000..398d083f2a5c
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20241130.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://anongit.gentoo.org/git/proj/crossdev.git
+ https://github.com/gentoo/crossdev
+ "
+else
+ SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Crossdev"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-apps/portage-2.1
+ app-shells/bash
+ sys-apps/gentoo-functions
+ sys-apps/config-site
+"
+BDEPEND="app-arch/xz-utils"
+
+src_install() {
+ default
+
+ if [[ ${PV} == "99999999" ]] ; then
+ sed -i "s:@CDEVPV@:${EGIT_VERSION}:" "${ED}"/usr/bin/crossdev || die
+ fi
+
+ dodir /usr/share/config.site.d
+ mv "${ED}"/usr/share/config.site{,.d/80crossdev.conf} || die
+}