summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-19 10:58:59 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-19 13:08:27 +0200
commitfc29ab72b5cf9b293ebb017c31411237da008e6b (patch)
treeba108e09e7817bb3bf6a706d1464802233295a6c /sys-devel/llvm/llvm-9999.ebuild
parentdev-python/pygit2: Use eapi7-ver.eclass (diff)
downloadgentoo-fc29ab72b5cf9b293ebb017c31411237da008e6b.tar.gz
gentoo-fc29ab72b5cf9b293ebb017c31411237da008e6b.tar.bz2
gentoo-fc29ab72b5cf9b293ebb017c31411237da008e6b.zip
sys-devel/llvm: Use eapi7-ver.eclass
Diffstat (limited to 'sys-devel/llvm/llvm-9999.ebuild')
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index ca558e0de2c0..c1fd48b6c2bd 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -8,8 +8,8 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils flag-o-matic git-r3 multilib-minimal pax-utils \
- python-any-r1 toolchain-funcs versionator
+inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
+ pax-utils python-any-r1 toolchain-funcs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="https://llvm.org/"
@@ -53,7 +53,7 @@ DEPEND="${RDEPEND}
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
- kernel_Darwin? ( <sys-libs/libcxx-$(get_version_component_range 1-3).9999 )
+ kernel_Darwin? ( <sys-libs/libcxx-$(ver_cut 1-3).9999 )
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )