summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-06-01 09:19:51 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-06-01 11:10:30 +0100
commite3b25bfd274fd0871cd4ad22e29ed13fabaa02b0 (patch)
treec989e08986df5772299fe041ebb8f04fe87f2786 /sys-devel/gcc/gcc-6.5.0-r1.ebuild
parentkde-apps/messagelib: Drop 18.12.3-r1 (diff)
downloadgentoo-e3b25bfd274fd0871cd4ad22e29ed13fabaa02b0.tar.gz
gentoo-e3b25bfd274fd0871cd4ad22e29ed13fabaa02b0.tar.bz2
gentoo-e3b25bfd274fd0871cd4ad22e29ed13fabaa02b0.zip
sys-devel/gcc: 6.5.0: cut 2 patchset
Single new patch: fix std::pair ABI deviation in 6.5 branch. This change will once again break ABI for existing 6.5 users but longer-term it should be more compatible with rest of gcc branches. Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-devel/gcc/gcc-6.5.0-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-6.5.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-devel/gcc/gcc-6.5.0-r1.ebuild b/sys-devel/gcc/gcc-6.5.0-r1.ebuild
new file mode 100644
index 000000000000..6c3f9ee42106
--- /dev/null
+++ b/sys-devel/gcc/gcc-6.5.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="2"
+
+inherit toolchain
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.13 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.13 )"
+fi