summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-28 02:08:42 -0400
committerSam James <sam@gentoo.org>2024-03-29 02:28:24 +0000
commit39eca52d93521a58c4205411d4ab11eca1cb1756 (patch)
tree421239a417edddb50a69d2b38e3e67535ffc1bb4 /sys-cluster/legion/legion-21.09.0-r1.ebuild
parentdev-libs/apr: simplify defining tool names to their basename (diff)
downloadgentoo-39eca52d93521a58c4205411d4ab11eca1cb1756.tar.gz
gentoo-39eca52d93521a58c4205411d4ab11eca1cb1756.tar.bz2
gentoo-39eca52d93521a58c4205411d4ab11eca1cb1756.zip
sys-cluster/legion: remove conceptually invalid repository clone url
This clearly wasn't tested (or else it was a cunning form of troll) to list the primary clone url as git://directoryname/reponame.git given that the directory name "StanfordLegion" is not a valid hostname or IP address. If I had to hazard the wildest of wild guesses as to what this was intended to do, it was intended to allow cloning from github.com over your choice of git:// or https:// protocols. Which leaves open the alternative question "why in G-ds name...". In any case, it doesn't matter since github hasn't offered git:// support for quite some time, so even if it worked, it wouldn't work. This change was made by github for the same reason that portage scolds you for using it: * git-r3: git protocol is completely insecure and may render the ebuild * easily susceptible to MITM attacks (even if used only as fallback). Please * use https instead. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/legion/legion-21.09.0-r1.ebuild')
-rw-r--r--sys-cluster/legion/legion-21.09.0-r1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/sys-cluster/legion/legion-21.09.0-r1.ebuild b/sys-cluster/legion/legion-21.09.0-r1.ebuild
index 55c79a8cda25..8a7849ea2d4e 100644
--- a/sys-cluster/legion/legion-21.09.0-r1.ebuild
+++ b/sys-cluster/legion/legion-21.09.0-r1.ebuild
@@ -9,7 +9,7 @@ DESCRIPTION="A data-centric parallel programming system"
HOMEPAGE="https://legion.stanford.edu/"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+ EGIT_REPO_URI="https://github.com/StanfordLegion/${PN}.git"
else
SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
S="${WORKDIR}"/${PN}-${P}