summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-07-27 22:18:03 -0400
committerMike Gilbert <floppym@gentoo.org>2022-07-27 22:18:03 -0400
commitabc80218d746fd4d02b4a75bca6ad67fe2ff5d71 (patch)
tree60cb0a0acf17d0cb86e0dd0b21285e9296627b83 /sys-boot
parentmail-mta/msmtp: allow linking against dev-libs/libretls (diff)
downloadgentoo-abc80218d746fd4d02b4a75bca6ad67fe2ff5d71.tar.gz
gentoo-abc80218d746fd4d02b4a75bca6ad67fe2ff5d71.tar.bz2
gentoo-abc80218d746fd4d02b4a75bca6ad67fe2ff5d71.zip
sys-boot/efibootmgr: add 18
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/efibootmgr/Manifest1
-rw-r--r--sys-boot/efibootmgr/efibootmgr-18.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/Manifest b/sys-boot/efibootmgr/Manifest
index 14ff697c3b2f..07d8e0fab978 100644
--- a/sys-boot/efibootmgr/Manifest
+++ b/sys-boot/efibootmgr/Manifest
@@ -1 +1,2 @@
DIST efibootmgr-17.tar.gz 41643 BLAKE2B a1995a5df74766f762d2eb971fd6095edea8d0a498c9dd1100515866b40c38ae2f299aae51f12767850ec23fbe4709c2c7428dd48755fbec499669b69f6432c9 SHA512 10c7ad9a79f23dcd4708dc4f42701196af7aa11f5e9a6468ea51f7013d4caeba6c92527ba1304f6e3b2ef3b51b3b69ea1a30f81bb099a8aea49eeb30eb631e1d
+DIST efibootmgr-18.tar.gz 45220 BLAKE2B 6bc3f39ee395d2045e78b19876fd9404ba41443259e9ad7446671d768a63dc1418d5a192600392fd95251159d80479008a2c22b4cd503bba2f4a869850cb3652 SHA512 04e40a705cb82440fd823043b598ef9fd1acc2ceda3e8d043a93e49d43ea9481b7386cad0f46de9862beff19b8a5480d79e7d6522ae584aff6655472f967764d
diff --git a/sys-boot/efibootmgr/efibootmgr-18.ebuild b/sys-boot/efibootmgr/efibootmgr-18.ebuild
new file mode 100644
index 000000000000..0110536e8690
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/rhinstaller/efibootmgr"
+SRC_URI="https://github.com/rhboot/efibootmgr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ sys-apps/pciutils
+ >=sys-libs/efivar-37:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i 's/-Werror //' Make.defaults || die
+}
+
+src_configure() {
+ tc-export CC
+ export EFIDIR="Gentoo"
+}
+
+src_compile() {
+ emake PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}