summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-04-06 22:17:47 +0100
committerMarek Szuba <marecki@gentoo.org>2022-04-06 22:44:31 +0100
commit441b899f3fc350094b71a017199d1c380ee9b04e (patch)
tree3129f6308d4a3a66bbf8bd9b136f34ef57ab49cc /sys-block
parentapp-shells/fish: Fix linking with libatomic (diff)
downloadgentoo-441b899f3fc350094b71a017199d1c380ee9b04e.tar.gz
gentoo-441b899f3fc350094b71a017199d1c380ee9b04e.tar.bz2
gentoo-441b899f3fc350094b71a017199d1c380ee9b04e.zip
sys-block/whdd: update EAPI 6 -> 8
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/whdd/Manifest1
-rw-r--r--sys-block/whdd/whdd-3.0.1-r2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-block/whdd/Manifest b/sys-block/whdd/Manifest
index 1c3b409a08e3..79b94aec9732 100644
--- a/sys-block/whdd/Manifest
+++ b/sys-block/whdd/Manifest
@@ -1 +1,2 @@
+DIST whdd-3.0.1-rel.tar.gz 45657 BLAKE2B 9730e61580359c95fc3e3d23540f3b10e75b476e634cce3be744b8849193f43f968f227bdbd25a0c643106c1343b27070c8b51f33278e902ab54991a05eee021 SHA512 6d5d8dad7537118a5915a29a549e18595da1b6ba031f0ca661805ad0033fd48f32804eb307f67e7b31d6002e708ae578a32aff366f3e610ab36b25f0a4e50803
DIST whdd-3.0.1.tar.gz 45671 BLAKE2B f16bcfc09356f43b5ae303e007cc3f0930316c67aa3c8622ffc7a3f6ee0f1c5339d7ff32e9b4707a42388fc955f70bf7d3ccc4bd36082d5592a5852d646832c7 SHA512 2cc207d5f0e5da1018ce4ec46f369cdd5c3ed2e55c063f583f8ca68f37949265d4ed8b6ea3ff9133a44cf254a95c3e819ba90f9d822aa3bc2f994cb16d0dc877
diff --git a/sys-block/whdd/whdd-3.0.1-r2.ebuild b/sys-block/whdd/whdd-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..29aeee9b5759
--- /dev/null
+++ b/sys-block/whdd/whdd-3.0.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-rel.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-util/dialog:=
+ sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}