summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny Gutbrod <gentoo@tastytea.de>2019-11-23 02:01:10 +0100
committerCraig Andrews <candrews@gentoo.org>2019-11-24 21:50:52 -0500
commitd1c81e7eac1b85bb927f910f8f594f446b450b6d (patch)
tree2c29cd7f3313a2f4c90ea7902ab5e5565a3cfe1d /sys-auth/google-authenticator/google-authenticator-1.06.ebuild
parentsys-auth/google-authenticator: Add Ronny Gudbrod as maintainer. (diff)
downloadgentoo-d1c81e7eac1b85bb927f910f8f594f446b450b6d.tar.gz
gentoo-d1c81e7eac1b85bb927f910f8f594f446b450b6d.tar.bz2
gentoo-d1c81e7eac1b85bb927f910f8f594f446b450b6d.zip
sys-auth/google-authenticator: Version bump 1.06.
Signed-off-by: Ronny Gutbrod <gentoo@tastytea.de> Closes: https://bugs.gentoo.org/699182 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'sys-auth/google-authenticator/google-authenticator-1.06.ebuild')
-rw-r--r--sys-auth/google-authenticator/google-authenticator-1.06.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/google-authenticator/google-authenticator-1.06.ebuild b/sys-auth/google-authenticator/google-authenticator-1.06.ebuild
new file mode 100644
index 000000000000..a087b7c55504
--- /dev/null
+++ b/sys-auth/google-authenticator/google-authenticator-1.06.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # We might want to use getpam_mod_dir from pam eclass,
+ # but the build already appends "/security" for us.
+ econf --libdir="/$(get_libdir)"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "For further information see"
+ elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+ elog ""
+ elog "If you want support for QR-Codes, install media-gfx/qrencode."
+ fi
+}