summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-03-09 14:28:58 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-09 14:56:28 +0100
commit3c1ca7b3260d4cb439fa4da7fcecdf0c92ce1b4f (patch)
tree55f38eaa14798fb4c3db13dc383cfb3fe37f209a /sys-auth/AusweisApp
parentx11-misc/dunst: update live ebuild (diff)
downloadgentoo-3c1ca7b3260d4cb439fa4da7fcecdf0c92ce1b4f.tar.gz
gentoo-3c1ca7b3260d4cb439fa4da7fcecdf0c92ce1b4f.tar.bz2
gentoo-3c1ca7b3260d4cb439fa4da7fcecdf0c92ce1b4f.zip
sys-auth/AusweisApp: rename sys-auth/AusweisApp2
Closes: https://bugs.gentoo.org/926173 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-auth/AusweisApp')
-rw-r--r--sys-auth/AusweisApp/AusweisApp-2.0.3.ebuild47
-rw-r--r--sys-auth/AusweisApp/AusweisApp-2.1.0.ebuild47
-rw-r--r--sys-auth/AusweisApp/AusweisApp-9999.ebuild47
-rw-r--r--sys-auth/AusweisApp/Manifest2
-rw-r--r--sys-auth/AusweisApp/metadata.xml11
5 files changed, 154 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp/AusweisApp-2.0.3.ebuild b/sys-auth/AusweisApp/AusweisApp-2.0.3.ebuild
new file mode 100644
index 000000000000..f791a20ba107
--- /dev/null
+++ b/sys-auth/AusweisApp/AusweisApp-2.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp/AusweisApp-2.1.0.ebuild b/sys-auth/AusweisApp/AusweisApp-2.1.0.ebuild
new file mode 100644
index 000000000000..d86746427953
--- /dev/null
+++ b/sys-auth/AusweisApp/AusweisApp-2.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-qt/qtshadertools:6
+ dev-qt/qttools:6[linguist]
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtbase:6[concurrent,network,widgets]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtscxml:6[qml]
+ dev-qt/qtsvg:6
+ dev-qt/qtwebsockets:6[qml]
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp/AusweisApp-9999.ebuild b/sys-auth/AusweisApp/AusweisApp-9999.ebuild
new file mode 100644
index 000000000000..2ee0eb3209a0
--- /dev/null
+++ b/sys-auth/AusweisApp/AusweisApp-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake git-r3 xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+EGIT_REPO_URI="https://github.com/Governikus/AusweisApp.git"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_SHARED_LIBS=OFF )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp/Manifest b/sys-auth/AusweisApp/Manifest
new file mode 100644
index 000000000000..bb557a4dc39f
--- /dev/null
+++ b/sys-auth/AusweisApp/Manifest
@@ -0,0 +1,2 @@
+DIST AusweisApp-2.0.3.tar.gz 9125557 BLAKE2B 6d32e0d451259bfb44ac99dce9dee3e66afd07d5c78c8f033703213888fb68c5d3ee9f8374d1ab79cd364061e78d98ce0c21fc5d6957f601bd88e5e3e6b2489d SHA512 4f492d137c1f38d3ff5ae70afc28d44bd86ce2034166e8ea7ca44e91161301a739ddcf985c76b14147485f6bc4e30e316db50db86eda7e2de1b7344c37091cd4
+DIST AusweisApp-2.1.0.tar.gz 5876657 BLAKE2B 54c8676dda53a667104f8edf8fc70fc4ca736b1207bea0ce2a5fc0a628216ce4f001adac03308fceccbb8ad834d171f364ac6b4e948ada26d6983ede827fd10e SHA512 a7186bdfe3ebd6779588dc6fa219fcc2f60d36c62a8b9956bbdc86e4962120e46b39266e7207cf0de4d84f9212d1616bbec9f8901cb0a112bcfcae1684f3ff75
diff --git a/sys-auth/AusweisApp/metadata.xml b/sys-auth/AusweisApp/metadata.xml
new file mode 100644
index 000000000000..2b138ddc526e
--- /dev/null
+++ b/sys-auth/AusweisApp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Governikus/AusweisApp</remote-id>
+ </upstream>
+</pkgmetadata>