summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-07 19:58:35 +0000
committerSam James <sam@gentoo.org>2024-03-07 20:21:02 +0000
commitbbd21e43dff806c1b728451432f646b61c0212e8 (patch)
tree828db9ca0e21a87398b397564f6c792426eae292 /sys-apps
parentsys-libs/minizip-ng: add 4.0.5 (diff)
downloadgentoo-bbd21e43dff806c1b728451432f646b61c0212e8.tar.gz
gentoo-bbd21e43dff806c1b728451432f646b61c0212e8.tar.bz2
gentoo-bbd21e43dff806c1b728451432f646b61c0212e8.zip
sys-apps/kmod: add 32
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/kmod/Manifest1
-rw-r--r--sys-apps/kmod/kmod-32.ebuild153
-rw-r--r--sys-apps/kmod/kmod-9999.ebuild1
3 files changed, 154 insertions, 1 deletions
diff --git a/sys-apps/kmod/Manifest b/sys-apps/kmod/Manifest
index 554efc99d6a0..0d9fcf490e5c 100644
--- a/sys-apps/kmod/Manifest
+++ b/sys-apps/kmod/Manifest
@@ -1 +1,2 @@
DIST kmod-31.tar.xz 570936 BLAKE2B 0dc8572da570315cf0aadd87fa7e83d0f88dea91c8566749e6f3004f9a6df916dce337ca99ea5929d41f45b408c1e3effa50f9d24615d7fa28688150a5ce91cf SHA512 05ca70381808bec5f262b94db625662c385408988178a35e4aaf4960ee0716dc0cbfc327160ea4b61098d0c2130ab1b5142ea8156bea8e06ded7f4d288b6d085
+DIST kmod-32.tar.xz 511988 BLAKE2B 5b5dac4639406549b23bb1da44bedd86a42885304ef4c7c67344dc8fd70b9e0ca3f83d033c6b80f6e00371d7188e205f4b68fadc56a9ddbf9d6a9d28e9b1e9a4 SHA512 29162135aabd025dff178a4147a754b5da5964855dbeee65ca867dec3b84437f35c1c97f0f027e974a021d3ee9a4940309a716859cc3cfe93c7ed0aada338f24
diff --git a/sys-apps/kmod/kmod-32.ebuild b/sys-apps/kmod/kmod-32.ebuild
new file mode 100644
index 000000000000..9d4a9de69ccb
--- /dev/null
+++ b/sys-apps/kmod/kmod-32.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools libtool bash-completion-r1
+
+DESCRIPTION="Library and tools for managing linux kernel modules"
+HOMEPAGE="https://git.kernel.org/?p=utils/kernel/kmod/kmod.git"
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kernel/kmod/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="debug doc +lzma pkcs7 static-libs +tools +zlib +zstd"
+
+# Upstream does not support running the test suite with custom configure flags.
+# I was also told that the test suite is intended for kmod developers.
+# So we have to restrict it.
+# See bug #408915.
+#RESTRICT="test"
+
+# - >=zlib-1.2.6 required because of bug #427130
+# - Block systemd below 217 for -static-nodes-indicate-that-creation-of-static-nodes-.patch
+# - >=zstd-1.5.2-r1 required for bug #771078
+RDEPEND="
+ !sys-apps/module-init-tools
+ !sys-apps/modutils
+ !<sys-apps/openrc-0.13.8
+ !<sys-apps/systemd-216-r3
+ lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
+ pkcs7? ( >=dev-libs/openssl-1.1.0:= )
+ zlib? ( >=sys-libs/zlib-1.2.6 )
+ zstd? ( >=app-arch/zstd-1.5.2-r1:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? (
+ dev-util/gtk-doc
+ dev-build/gtk-doc-am
+ )
+ lzma? ( virtual/pkgconfig )
+ zlib? ( virtual/pkgconfig )
+"
+if [[ ${PV} == 9999* ]]; then
+ BDEPEND+=" dev-libs/libxslt"
+fi
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-31-musl-basename.patch
+)
+
+src_prepare() {
+ default
+
+ if [[ ! -e configure ]] || use doc ; then
+ if use doc; then
+ cp "${BROOT}"/usr/share/aclocal/gtk-doc.m4 m4 || die
+ gtkdocize --copy --docdir libkmod/docs || die
+ else
+ touch libkmod/docs/gtk-doc.make
+ fi
+ eautoreconf
+ else
+ elibtoolize
+ fi
+
+ # Restore possibility of running --enable-static, bug #472608
+ sed -i \
+ -e '/--enable-static is not supported by kmod/s:as_fn_error:echo:' \
+ configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --enable-shared
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ --with-rootlibdir="${EPREFIX}/$(get_libdir)"
+ $(use_enable debug)
+ $(usev doc '--enable-gtk-doc')
+ $(use_enable static-libs static)
+ $(use_enable tools)
+ $(use_with lzma xz)
+ $(use_with pkcs7 openssl)
+ $(use_with zlib)
+ $(use_with zstd)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ if use tools; then
+ local cmd
+ for cmd in depmod insmod modprobe rmmod; do
+ dosym ../bin/kmod /sbin/${cmd}
+ done
+
+ # These are also usable as normal user
+ for cmd in lsmod modinfo; do
+ dosym kmod /bin/${cmd}
+ done
+ fi
+
+ cat <<-EOF > "${T}"/usb-load-ehci-first.conf
+ softdep uhci_hcd pre: ehci_hcd
+ softdep ohci_hcd pre: ehci_hcd
+ EOF
+
+ insinto /lib/modprobe.d
+ # bug #260139
+ doins "${T}"/usb-load-ehci-first.conf
+
+ newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
+}
+
+pkg_postinst() {
+ if [[ -L ${EROOT}/etc/runlevels/boot/static-nodes ]]; then
+ ewarn "Removing old conflicting static-nodes init script from the boot runlevel"
+ rm -f "${EROOT}"/etc/runlevels/boot/static-nodes
+ fi
+
+ # Add kmod to the runlevel automatically if this is the first install of this package.
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ if [[ ! -d ${EROOT}/etc/runlevels/sysinit ]]; then
+ mkdir -p "${EROOT}"/etc/runlevels/sysinit
+ fi
+ if [[ -x ${EROOT}/etc/init.d/kmod-static-nodes ]]; then
+ ln -s /etc/init.d/kmod-static-nodes "${EROOT}"/etc/runlevels/sysinit/kmod-static-nodes
+ fi
+ fi
+
+ if [[ -e ${EROOT}/etc/runlevels/sysinit ]]; then
+ if ! has_version sys-apps/systemd && [[ ! -e ${EROOT}/etc/runlevels/sysinit/kmod-static-nodes ]]; then
+ ewarn
+ ewarn "You need to add kmod-static-nodes to the sysinit runlevel for"
+ ewarn "kernel modules to have required static nodes!"
+ ewarn "Run this command:"
+ ewarn "\trc-update add kmod-static-nodes sysinit"
+ fi
+ fi
+}
diff --git a/sys-apps/kmod/kmod-9999.ebuild b/sys-apps/kmod/kmod-9999.ebuild
index d0de1d663e3e..9d4a9de69ccb 100644
--- a/sys-apps/kmod/kmod-9999.ebuild
+++ b/sys-apps/kmod/kmod-9999.ebuild
@@ -83,7 +83,6 @@ src_configure() {
--enable-shared
--with-bashcompletiondir="$(get_bashcompdir)"
--with-rootlibdir="${EPREFIX}/$(get_libdir)"
- --disable-python
$(use_enable debug)
$(usev doc '--enable-gtk-doc')
$(use_enable static-libs static)