summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-09-01 10:04:38 -0500
committerBen Kohler <bkohler@gentoo.org>2023-09-01 10:24:50 -0500
commit871a185130fc2075c9e14c38be5d498a6b354c51 (patch)
tree8620f1858f9a1b7d45419b57f547f3ef7c62ef0e /sys-apps
parentnet-wireless/iwd: enable start via dbus for NetworkManager (diff)
downloadgentoo-871a185130fc2075c9e14c38be5d498a6b354c51.tar.gz
gentoo-871a185130fc2075c9e14c38be5d498a6b354c51.tar.bz2
gentoo-871a185130fc2075c9e14c38be5d498a6b354c51.zip
sys-apps/memtest86-bin: add 10.6_p2000
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/memtest86-bin/Manifest1
-rw-r--r--sys-apps/memtest86-bin/memtest86-bin-10.6_p2000.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/memtest86-bin/Manifest b/sys-apps/memtest86-bin/Manifest
index dfcab4766fbf..4482721345a6 100644
--- a/sys-apps/memtest86-bin/Manifest
+++ b/sys-apps/memtest86-bin/Manifest
@@ -1 +1,2 @@
DIST memtest86-bin-10.6.zip 11817380 BLAKE2B cad80d5230574eb0147007e9233ee79e276931856692a0b9e5b9db878de31f3a90eeaf1520a29477208b4f8276ae134f9b7693ffe9e55128d20bb0ad0d0cdb1d SHA512 7ffaf44bee4ca0c6a521b53351ba8514212beff2dfa640ef34cfb44390337fdefe5f15ca36d61e16353acb55edc7906c4d3544c58348f1550a906509c5e8db4c
+DIST memtest86-bin-10.6_p2000.zip 11816675 BLAKE2B 4efe2560e2a4812a8c5bc778c0252268053dffbe77529dee249d5ac6ec1b23c1dd076e06c35b90ecbb8133e3f62134f3daff3f92a214102b81e0dbe76c01159b SHA512 5ee481b5e3a920f287576ef14e77cdef440356b7c3e5daba22823f8728692b1d80b65b9f7238963f87832bb3984cf663cb5e40628bf4bb23c379e0f989c323d2
diff --git a/sys-apps/memtest86-bin/memtest86-bin-10.6_p2000.ebuild b/sys-apps/memtest86-bin/memtest86-bin-10.6_p2000.ebuild
new file mode 100644
index 000000000000..54ff7712597b
--- /dev/null
+++ b/sys-apps/memtest86-bin/memtest86-bin-10.6_p2000.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit mount-boot secureboot
+
+DESCRIPTION="Stand alone memory testing software for x86 EFI hardware"
+HOMEPAGE="http://www.memtest86.com/"
+SRC_URI="https://www.memtest86.com/downloads/memtest86-usb.zip -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="PassMark-EULA"
+RESTRICT="mirror bindist"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+BDEPEND="
+ app-arch/unzip
+ sys-fs/fatcat
+"
+
+src_unpack() {
+ default
+ fatcat -O 1048576 -r /EFI/BOOT/BOOTX64.efi memtest86-usb.img > ${PN}.efi || die
+}
+
+src_install() {
+ insinto /boot
+ doins ${PN}.efi
+
+ exeinto /etc/grub.d/
+ newexe "${FILESDIR}"/${PN}-grub.d 39_memtest86-bin
+
+ dodoc MemTest86_User_Guide_UEFI.pdf
+
+ secureboot_auto_sign --in-place
+}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+
+ if [ ! -e /sys/firmware/efi ]; then
+ ewarn "WARNING: You appear to be booted in BIOS mode but ${PN} is an EFI-only tool."
+ fi
+}