summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-26 08:27:11 +0000
committerSam James <sam@gentoo.org>2022-12-26 08:33:03 +0000
commit7d1baf30c68a76b9530c5752a0de9e5569221017 (patch)
treedc6c7de73d88731a84180f3f95f592963d44200b /sys-apps
parentsys-apps/pcsc-tools: drop 1.5.7-r1 (diff)
downloadgentoo-7d1baf30c68a76b9530c5752a0de9e5569221017.tar.gz
gentoo-7d1baf30c68a76b9530c5752a0de9e5569221017.tar.bz2
gentoo-7d1baf30c68a76b9530c5752a0de9e5569221017.zip
sys-apps/sg3_utils: drop 1.46-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sg3_utils/Manifest1
-rw-r--r--sys-apps/sg3_utils/files/sg3_utils-1.46-musl-drand48-compat.patch99
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild42
3 files changed, 0 insertions, 142 deletions
diff --git a/sys-apps/sg3_utils/Manifest b/sys-apps/sg3_utils/Manifest
index 39cbf40dd6fb..4bbf431de396 100644
--- a/sys-apps/sg3_utils/Manifest
+++ b/sys-apps/sg3_utils/Manifest
@@ -1,2 +1 @@
-DIST sg3_utils-1.46.tar.xz 1031800 BLAKE2B 034af23d10da49938979ea4d0041c6ce4309b9ceac13f06bd524011dccf285e88fbc5f4c3f261ec3e316db86278ccff235015de43d98b0b62ff05a2f98df0850 SHA512 0b4caab97ccc11fb45e88219e460b37c6ff69b8f3c79e513279aef51783ff22399d141253abdbf55db198db0815bc39d30e9b1e3bd7dda5e15c5f4dae3fe89cf
DIST sg3_utils-1.47.tar.xz 1046904 BLAKE2B 6efadd86f6d466469f5d5d3f53b2b6bf01143695db19e96b55a13a606d8a36d5571e390fed0b0990371dc4b77714f88c03f440a4468f6863544c0d21b2e3ef73 SHA512 ef072b8f0012d0944e21d2134aff7125e24ea24d1cbbb1aa79160e844f9a60236f1e244437a3bc08a22a7e99f613adad4a05ae5cc3916ded5a72d162cd3aa163
diff --git a/sys-apps/sg3_utils/files/sg3_utils-1.46-musl-drand48-compat.patch b/sys-apps/sg3_utils/files/sg3_utils-1.46-musl-drand48-compat.patch
deleted file mode 100644
index d4152c3d2651..000000000000
--- a/sys-apps/sg3_utils/files/sg3_utils-1.46-musl-drand48-compat.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-diff -Naurp sg3_utils-1.46.orig/doc/sg_dd.8 sg3_utils-1.46/doc/sg_dd.8
---- sg3_utils-1.46.orig/doc/sg_dd.8 2021-03-22 00:36:43.000000000 -0400
-+++ sg3_utils-1.46/doc/sg_dd.8 2021-08-16 14:07:16.703526168 -0400
-@@ -394,7 +394,7 @@ random
- this flag is only active with \fIiflag=\fR and when given replaces
- \fIif=IFILE\fR. If both are given an error is generated. The input will
- be a stream of pseudo random bytes. The Linux getrandom(2) system call is
--used to create a seed and thereadter mrand48_r(3) is used to generate a
-+used to create a seed and thereadter mrand48(3) is used to generate a
- pseudo random sequence, 4 bytes at a time. The quality of the randomness
- can be viewed with the ent(1) utility. This is not a high quality random
- number generator, it is built for speed, not quality. One application is
-diff -Naurp sg3_utils-1.46.orig/src/sg_dd.c sg3_utils-1.46/src/sg_dd.c
---- sg3_utils-1.46.orig/src/sg_dd.c 2021-03-27 20:58:36.000000000 -0400
-+++ sg3_utils-1.46/src/sg_dd.c 2021-08-16 12:56:26.316550042 -0400
-@@ -176,7 +176,6 @@ static uint8_t * free_zeros_buff = NULL;
- static int read_long_blk_inc = READ_LONG_DEF_BLK_INC;
-
- static long seed;
--static struct drand48_data drand;/* opaque, used by srand48_r and mrand48_r */
-
- static const char * proc_allow_dio = "/proc/scsi/sg/allow_dio";
-
-@@ -2124,7 +2123,7 @@ main(int argc, char * argv[])
- #endif
- if (verbose > 1)
- pr2serr("seed=%ld\n", seed);
-- srand48_r(seed, &drand);
-+ srand48(seed);
- } else if (iflag.zero) {
- ccp = "<zero bytes>";
- cc2p = "00";
-@@ -2401,7 +2400,7 @@ main(int argc, char * argv[])
- for (kk = 0; kk < blocks; ++kk, bp += blk_sz) {
- for (j = 0; j < blk_sz; j += jbump) {
- /* mrand48 takes uniformly from [-2^31, 2^31) */
-- mrand48_r(&drand, &rn);
-+ rn = mrand48();
- *((uint32_t *)(bp + j)) = (uint32_t)rn;
- }
- }
-diff -Naurp sg3_utils-1.46.orig/testing/sgh_dd.cpp sg3_utils-1.46/testing/sgh_dd.cpp
---- sg3_utils-1.46.orig/testing/sgh_dd.cpp 2021-03-28 21:27:17.000000000 -0400
-+++ sg3_utils-1.46/testing/sgh_dd.cpp 2021-08-16 14:06:37.262536902 -0400
-@@ -312,7 +312,6 @@ typedef struct request_element
- uint32_t in_mrq_q_blks;
- uint32_t out_mrq_q_blks;
- long seed;
-- struct drand48_data drand; /* opaque, used by srand48_r and mrand48_r */
- pthread_t mrq_abort_thread_id;
- Mrq_abort_info mai;
- } Rq_elem;
-@@ -1491,7 +1490,7 @@ read_write_thread(void * v_tip)
- #endif
- if (vb > 1)
- pr2serr_lk("thread=%d: seed=%ld\n", rep->id, rep->seed);
-- srand48_r(rep->seed, &rep->drand);
-+ srand48(rep->seed);
- }
- if (clp->in_flags.same_fds || clp->out_flags.same_fds)
- ;
-@@ -1804,7 +1803,7 @@ normal_in_rd(Rq_elem * rep, int blocks)
- for (k = 0, bp = rep->buffp; k < blocks; ++k, bp += clp->bs) {
- for (j = 0; j < clp->bs; j += jbump) {
- /* mrand48 takes uniformly from [-2^31, 2^31) */
-- mrand48_r(&rep->drand, &rn);
-+ rn = mrand48();
- *((uint32_t *)(bp + j)) = (uint32_t)rn;
- }
- }
-diff -Naurp sg3_utils-1.46.orig/testing/sg_mrq_dd.cpp sg3_utils-1.46/testing/sg_mrq_dd.cpp
---- sg3_utils-1.46.orig/testing/sg_mrq_dd.cpp 2021-03-28 21:27:17.000000000 -0400
-+++ sg3_utils-1.46/testing/sg_mrq_dd.cpp 2021-08-16 14:06:45.842752108 -0400
-@@ -313,7 +313,6 @@ typedef struct request_element
- int out_local_partial;
- int in_resid_bytes;
- long seed;
-- struct drand48_data drand; /* opaque, used by srand48_r and mrand48_r */
- } Rq_elem;
-
- /* Additional parameters for sg_start_io() and sg_finish_io() */
-@@ -1310,7 +1309,7 @@ read_write_thread(struct global_collecti
- #endif
- if (vb > 1)
- pr2serr_lk("[%d] %s: seed=%ld\n", id, __func__, rep->seed);
-- srand48_r(rep->seed, &rep->drand);
-+ srand48(rep->seed);
- }
-
- if (in_is_sg && clp->infp) {
-@@ -1524,7 +1523,7 @@ normal_in_rd(Rq_elem * rep, int64_t lba,
- for (k = 0; k < blocks; ++k, bp += clp->bs) {
- for (j = 0; j < clp->bs; j += jbump) {
- /* mrand48 takes uniformly from [-2^31, 2^31) */
-- mrand48_r(&rep->drand, &rn);
-+ rn = mrand48();
- *((uint32_t *)(bp + j)) = (uint32_t)rn;
- }
- }
diff --git a/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild b/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild
deleted file mode 100644
index 51068d8dc71a..000000000000
--- a/sys-apps/sg3_utils/sg3_utils-1.46-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="8"
-
-DESCRIPTION="Apps for querying the sg SCSI interface"
-HOMEPAGE="https://sg.danny.cz/sg/"
-#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI="https://sg.danny.cz/sg/p/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="static-libs"
-
-DEPEND="sys-devel/libtool"
-RDEPEND="!sys-apps/rescan-scsi-bus"
-
-PATCHES=(
- # Bug #808600
- "${FILESDIR}"/${PN}-1.46-musl-drand48-compat.patch
-)
-
-src_configure() {
- econf $(use_enable static-libs static)
-}
-
-src_install() {
- default
- dodoc COVERAGE doc/README examples/*.txt
- newdoc scripts/README README.scripts
-
- find "${ED}" -type f -name "*.la" -delete || die
-
- # Better fix for bug 231089; some packages look for sgutils2
- local path lib
- path="/usr/$(get_libdir)"
- for lib in "${ED}/"${path}/libsgutils2{,-${PV}}.*; do
- lib=${lib##*/}
- dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
- done
-}