summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-03-25 01:39:29 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-25 10:09:35 +0200
commit31b9f87dbb03f46a9ccb9d16c41436b3560c9b0e (patch)
treea9c3425ce281586bb4c8c35974d65a6e4b16550d /sys-apps
parentprofiles/license_groups: add supermicro license to EULA group (diff)
downloadgentoo-31b9f87dbb03f46a9ccb9d16c41436b3560c9b0e.tar.gz
gentoo-31b9f87dbb03f46a9ccb9d16c41436b3560c9b0e.tar.bz2
gentoo-31b9f87dbb03f46a9ccb9d16c41436b3560c9b0e.zip
sys-apps/ipmicfg: New package
Closes: https://bugs.gentoo.org/601318 Closes: https://github.com/gentoo/gentoo/pull/7304
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/ipmicfg/Manifest1
-rw-r--r--sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild60
-rw-r--r--sys-apps/ipmicfg/metadata.xml12
3 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/ipmicfg/Manifest b/sys-apps/ipmicfg/Manifest
new file mode 100644
index 000000000000..e35d9f114709
--- /dev/null
+++ b/sys-apps/ipmicfg/Manifest
@@ -0,0 +1 @@
+DIST IPMICFG_1.27.1_build.170901.zip 1667230 BLAKE2B 6411f735fed2e66f8dc012c480e6f9a4c2c9223643074514ca6fbb0db62df06fd78714c4a95ce92edc22a4473734a1d41a6c3bdb61268c73a628f08e7dc87c0e SHA512 9ed01a8a1eae7a7e41fafdbb3b666e7760057c960b65da547f0cf197b30b1a535fa2fe8357e13e6ccda0e0dd4474170b43ca3bc89f55c2de5df0160adde9377e
diff --git a/sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild b/sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild
new file mode 100644
index 000000000000..ce0d6c434345
--- /dev/null
+++ b/sys-apps/ipmicfg/ipmicfg-1.27.1.170901.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eapi7-ver
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN^^}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="An in-band utility for configuring Supermicro IPMI devices"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="ftp://ftp.supermicro.com/utility/${MY_PN}/${MY_PN}_${MY_PV}_build.${MY_DATE}.zip"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="supermicro"
+SLOT="0"
+
+RDEPEND="sys-libs/glibc"
+DEPEND="app-arch/unzip"
+
+RESTRICT="bindist fetch mirror strip"
+
+S="${WORKDIR}/${MY_PN}_${MY_PV}_build.${MY_DATE}"
+
+QA_PREBUILT="opt/ipmicfg/IPMICFG-Linux.x86 opt/ipmicfg/IPMICFG-Linux.x86_64"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=IPMI"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_install() {
+ # Choose ARCH
+ if use amd64; then
+ local my_arch_binary="x86_64"
+ local my_arch_folder="64bit"
+ else
+ local my_arch_binary="x86"
+ local my_arch_folder="32bit"
+ fi
+
+ # Install files
+ insinto "/opt/ipmicfg"
+ doins "Linux/${my_arch_folder}"/*.dat
+
+ # Install binary
+ exeinto "/opt/ipmicfg"
+ doexe "Linux/${my_arch_folder}/IPMICFG-Linux.${my_arch_binary}"
+
+ # Install symlink
+ dodir "/opt/bin"
+ dosym "../ipmicfg/IPMICFG-Linux.${my_arch_binary}" "/opt/bin/ipmicfg"
+
+ # Install docs
+ local DOCS=( "IPMICFG_UserGuide.pdf" "ReleaseNotes.txt" )
+ einstalldocs
+}
diff --git a/sys-apps/ipmicfg/metadata.xml b/sys-apps/ipmicfg/metadata.xml
new file mode 100644
index 000000000000..54d5423c4060
--- /dev/null
+++ b/sys-apps/ipmicfg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>