summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-14 04:32:17 +0000
committerSam James <sam@gentoo.org>2024-11-14 04:33:01 +0000
commit0af5b4968d579ce53f5e1e2f8274c90291493f2b (patch)
treeb8d3c88dab80d98aaa487de84cdcb24c95765c63 /sys-apps/usbutils
parentsys-block/mbuffer: add 20241007 (diff)
downloadgentoo-0af5b4968d579ce53f5e1e2f8274c90291493f2b.tar.gz
gentoo-0af5b4968d579ce53f5e1e2f8274c90291493f2b.tar.bz2
gentoo-0af5b4968d579ce53f5e1e2f8274c90291493f2b.zip
sys-apps/usbutils: add 018
* Switch to Meson * Drop usbreset I've not kept usbreset as in meson.build, it's marked as: """ By default, usbreset does not get installed as it could cause problems, it's in the repo for those that wish to try it out. """ If someone wants it, please file a bug to let us know. * Fix LICENSE to be GPL-2+ Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/usbutils')
-rw-r--r--sys-apps/usbutils/Manifest1
-rw-r--r--sys-apps/usbutils/usbutils-018.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/usbutils/Manifest b/sys-apps/usbutils/Manifest
index 3914e85a8480..6a2785cfee6d 100644
--- a/sys-apps/usbutils/Manifest
+++ b/sys-apps/usbutils/Manifest
@@ -1,2 +1,3 @@
DIST usbutils-016.tar.xz 169000 BLAKE2B 2f3af61e5a7abf48cdf0a4aebc901ca1570007b54d11ae74572e16bdeb2d8e73844d76af54bd812d6d4b84ddaf6e956132ecc9a8a2849a7bffc0643e29115a49 SHA512 4483038bf91c056cd2977f5e7f449c0a62d9152d6f5d64ab7bde438ab9c1c56fe524ba10b35781c2828edd0fe89379dbaed78fa7ffe78903cae0c4e3c460f9a0
DIST usbutils-017.tar.xz 168820 BLAKE2B 868c646ed6d38a38b9bd3ab85ba3a5e9362a97e476aeed6576c1b175caaf4ee688cb2c33756f02c9bf0aef9e7d58657331fc1c3b3314d86145b3d4f37124537e SHA512 eaebbc82eee4d940898f7a8de95ca49846c7c964e65c3d866b38735f8f3c8ccfed2b3a536bf2ef39a835a40a34c2273ac4d82b1012d0c693d4863cff14870d95
+DIST usbutils-018.tar.xz 120168 BLAKE2B 030f45afd5867ee38c8284a0741d1de63653a98746bfef42281390c5bdefbbb99c318d708e88ea2e28810d519d735da3103fe438befa889fc9b5ae9e21200992 SHA512 4f76c7a328746e17892c31d69cbd9a560c4384877e18d80076cef344a25b71b33387d803c98a9c6867b357a61e1a8a1a630884afe32128c3b6393dc186f216c8
diff --git a/sys-apps/usbutils/usbutils-018.ebuild b/sys-apps/usbutils/usbutils-018.ebuild
new file mode 100644
index 000000000000..d26898c292e5
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-018.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit meson python-single-r1
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="
+ https://www.kernel.org/pub/linux/utils/usb/usbutils/
+ https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/
+"
+SRC_URI="https://www.kernel.org/pub/linux/utils/usb/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ virtual/libusb:1=
+ virtual/libudev:=
+"
+RDEPEND="
+ ${DEPEND}
+ python? (
+ ${PYTHON_DEPS}
+ sys-apps/hwdata
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ python? ( ${PYTHON_DEPS} )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ use python && python_fix_shebang lsusb.py
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use python ; then
+ rm -f "${ED}"/usr/bin/lsusb.py || die
+ fi
+}