summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-09-26 20:22:51 +0100
committerSam James <sam@gentoo.org>2024-09-26 20:28:11 +0100
commitc0daa12fe012be01aa67ce2160e8eec80b77e137 (patch)
treed220995efab24fb6fbdb569ddeed8fcdc862fb02 /sys-apps/sg3_utils
parentsys-apps/systemd: drop hwids blocker (diff)
downloadgentoo-c0daa12fe012be01aa67ce2160e8eec80b77e137.tar.gz
gentoo-c0daa12fe012be01aa67ce2160e8eec80b77e137.tar.bz2
gentoo-c0daa12fe012be01aa67ce2160e8eec80b77e137.zip
sys-apps/sg3_utils: add 1.48
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/sg3_utils')
-rw-r--r--sys-apps/sg3_utils/Manifest1
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.48.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/Manifest b/sys-apps/sg3_utils/Manifest
index 4bbf431de396..f4c740c44347 100644
--- a/sys-apps/sg3_utils/Manifest
+++ b/sys-apps/sg3_utils/Manifest
@@ -1 +1,2 @@
DIST sg3_utils-1.47.tar.xz 1046904 BLAKE2B 6efadd86f6d466469f5d5d3f53b2b6bf01143695db19e96b55a13a606d8a36d5571e390fed0b0990371dc4b77714f88c03f440a4468f6863544c0d21b2e3ef73 SHA512 ef072b8f0012d0944e21d2134aff7125e24ea24d1cbbb1aa79160e844f9a60236f1e244437a3bc08a22a7e99f613adad4a05ae5cc3916ded5a72d162cd3aa163
+DIST sg3_utils-1.48.tar.xz 1211028 BLAKE2B 282ca9ad39f225aa9ce49e8ebd5f86f0786d2c6d0e1f237befee9535f2d4d7ab1316ec708a4f2cb43f84b0cb3bb431c641b3b3868e3e4f178020bf2a6c2955c1 SHA512 d4f586ac8a4ba9b5de5885657785e25251c8a42913332d6eca38f92b546c06e8e8aa0553c4b5c04f553cf2d0a9e4f34827f65ba596ef65e43dec36b4345f444a
diff --git a/sys-apps/sg3_utils/sg3_utils-1.48.ebuild b/sys-apps/sg3_utils/sg3_utils-1.48.ebuild
new file mode 100644
index 000000000000..01be99445cc5
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.48.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="https://sg.danny.cz/sg/"
+#SRC_URI="https://github.com/hreinecke/sg3_utils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://sg.danny.cz/sg/p/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="!sys-apps/rescan-scsi-bus"
+
+src_prepare() {
+ default
+ elibtoolize
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ dodoc COVERAGE doc/README examples/*.txt
+ newdoc scripts/README README.scripts
+
+ find "${ED}" -type f -name "*.la" -delete || die
+
+ # Better fix for bug 231089; some packages look for sgutils2
+ local path lib
+ path="/usr/$(get_libdir)"
+ for lib in "${ED}/"${path}/libsgutils2{,-${PV}}.*; do
+ lib=${lib##*/}
+ dosym "${lib}" "${path}/${lib/libsgutils2/libsgutils}"
+ done
+}