summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/pkgcore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/metadata.xml15
-rw-r--r--sys-apps/pkgcore/pkgcore-0.9.1.ebuild83
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild75
4 files changed, 174 insertions, 0 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
new file mode 100644
index 000000000000..9fee77687204
--- /dev/null
+++ b/sys-apps/pkgcore/Manifest
@@ -0,0 +1 @@
+DIST pkgcore-0.9.1.tar.gz 570633 SHA256 d5f556c7dcf69aa45f8bc80c95cc5273de389d21ab7932a1cd8babcd5aa2fc10 SHA512 3cd221070369af07729afa2af5bba20a544d2d58913a6e8d7da90b7a59d043fec906b7276032194cc5c86d84417793ba732f326a342b5ac439f1f2bf6b14a262 WHIRLPOOL f39f927f0334be9ab95ed6bf6b8074f707fcee57eb124dc25b48bdc40c4743959fa9826e7cec593f082233624335d753f09990ce3faf7a798abf442c8879bbda
diff --git a/sys-apps/pkgcore/metadata.xml b/sys-apps/pkgcore/metadata.xml
new file mode 100644
index 000000000000..1190705cdba4
--- /dev/null
+++ b/sys-apps/pkgcore/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+ <use>
+ <flag name="doc">Build and install API docs.</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">pkgcore</remote-id>
+ <remote-id type="github">pkgcore/pkgcore</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/pkgcore/pkgcore-0.9.1.ebuild b/sys-apps/pkgcore/pkgcore-0.9.1.ebuild
new file mode 100644
index 000000000000..89575fdf4f54
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.9.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore package manager"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/snakeoil-0.6.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+"
+
+pkg_setup() {
+ # disable snakeoil 2to3 caching...
+ unset PY2TO3_CACHEDIR
+
+ mydistutilsargs=(
+ build
+ --disable-html-docs
+ --disable-man-pages
+ )
+}
+
+python_compile_all() {
+ esetup.py $(use doc && echo 'build_docs')
+
+ if [[ ${PV} == *9999 ]]; then
+ esetup.py build_man
+ ln -s "${BUILD_DIR}/sphinx/man" man || die
+ fi
+
+ # symlinks generated manpages into source root
+ # dead symlinks are tolerated
+ ln -s "${BUILD_DIR}/sphinx/html" html || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+src_install() {
+ mydistutilsargs+=(
+ install
+ --disable-html-docs
+ --disable-man-pages
+ )
+
+ distutils-r1_src_install
+}
+
+python_install_all() {
+ local cmds=(
+ install_man
+ )
+ use doc && cmds+=(
+ install_docs --path="${ED%/}"/usr/share/doc/${PF}/html
+ )
+
+ distutils-r1_python_install "${cmds[@]}"
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ python_foreach_impl pplugincache
+}
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
new file mode 100644
index 000000000000..fca70364cc08
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="pkgcore package manager"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+IUSE="doc test"
+
+if [[ ${PV} == *9999 ]] ; then
+ SPHINX="dev-python/sphinx[${PYTHON_USEDEP}]"
+else
+ SPHINX="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+fi
+RDEPEND="=dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ ${SPHINX}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )
+"
+
+pkg_setup() {
+ # disable snakeoil 2to3 caching...
+ unset PY2TO3_CACHEDIR
+}
+
+python_compile_all() {
+ if [[ ${PV} == *9999 ]]; then
+ esetup.py build_man
+ ln -s "${BUILD_DIR}/sphinx/man" man || die
+ fi
+
+ if use doc; then
+ esetup.py build_docs
+ ln -s "${BUILD_DIR}/sphinx/html" html || die
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ local cmds=(
+ install_man
+ )
+ use doc && cmds+=(
+ install_docs --path="${ED%/}"/usr/share/doc/${PF}/html
+ )
+
+ distutils-r1_python_install "${cmds[@]}"
+ distutils-r1_python_install_all
+
+ insinto /usr/share/zsh/site-functions
+ doins completion/zsh/*
+}
+
+pkg_postinst() {
+ python_foreach_impl pplugincache
+}