summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-10-27 17:57:13 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-10-27 17:57:40 +0200
commiteffecc045f78dabf595f56e9d289d4aa082757ca (patch)
tree01b506394fcf665ed9355b6522327ba09fe97dbf /sys-apps/pacman
parentsys-apps/pacman: Rev bump to fix CVE-2016-5434 (bug #585940) (diff)
downloadgentoo-effecc045f78dabf595f56e9d289d4aa082757ca.tar.gz
gentoo-effecc045f78dabf595f56e9d289d4aa082757ca.tar.bz2
gentoo-effecc045f78dabf595f56e9d289d4aa082757ca.zip
sys-apps/pacman: Security cleanup (bug #585940)
Closes: https://github.com/gentoo/gentoo/pull/6046 Package-Manager: Portage-2.3.11, Repoman-2.3.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-apps/pacman')
-rw-r--r--sys-apps/pacman/pacman-5.0.2.ebuild86
1 files changed, 0 insertions, 86 deletions
diff --git a/sys-apps/pacman/pacman-5.0.2.ebuild b/sys-apps/pacman/pacman-5.0.2.ebuild
deleted file mode 100644
index 2cea26f9fc53..000000000000
--- a/sys-apps/pacman/pacman-5.0.2.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-
-DESCRIPTION="Archlinux's binary package manager"
-HOMEPAGE="https://archlinux.org/pacman/"
-
-if [[ ${PV} == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.archlinux.org/pacman.git"
-else
- SRC_URI="https://sources.archlinux.org/other/pacman/${P}.tar.gz"
- # Do *not* re-add ~x86!
- # https://www.archlinux.org/news/phasing-out-i686-support/
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-IUSE="curl debug doc +gpg"
-COMMON_DEPEND="app-arch/libarchive:=[lzma]
- gpg? ( >=app-crypt/gpgme-1.4.0:= )
- dev-libs/openssl:0=
- curl? ( net-misc/curl )
- virtual/libiconv
- virtual/libintl"
-RDEPEND="${COMMON_DEPEND}"
-# create manpages *everytime*
-DEPEND="${COMMON_DEPEND}
- app-text/asciidoc
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- # Remove a line that adds -Werror in ./configure when --enable-debug
- # is passed:
- sed -i -e '/-Werror/d' configure.ac || die
-
- default
-}
-
-src_configure() {
- local myeconfargs=(
- --localstatedir=/var
- --disable-git-version
- --with-openssl
- # Help protect user from shooting his/her Gentoo installation
- # in its foot.
- --with-root-dir="${EPREFIX}/var/chroot/archlinux"
- $(use_enable debug)
- # build always manpages
- --with-doc
- # full doc with doxygen
- $(use_enable doc doxygen)
- $(use_with curl libcurl)
- $(use_with gpg gpgme)
- )
- econf "${myeconfargs[@]}"
-}
-src_install() {
- dodir /etc/pacman.d/
- default
-}
-
-pkg_postinst() {
- einfo ""
- einfo "The default root dir was set to ${EPREFIX}/var/chroot/archlinux"
- einfo "to avoid breaking Gentoo systems due to oscitancy."
- einfo "You need to create this path by yourself (or choose another via"
- einfo "pacman’s parameter -r|--root)."
- einfo ""
- einfo ""
- einfo "You will need to setup at least one mirror in /etc/pacman.d/mirrorlist."
- einfo "Please generate it manually according to the Archlinux documentation:"
- einfo "https://wiki.archlinux.org/index.php/Mirror"
- einfo ""
- einfo ""
- einfo "Archlinux is dropping support for x86 (i686 called there) entirely"
- einfo "in Nov 2017. Keep this in mind when setting up new systems."
- einfo "For more details see"
- einfo "https://www.archlinux.org/news/phasing-out-i686-support"
- einfo ""
-}