summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2017-05-25 22:03:18 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-30 16:09:16 +0200
commit9ba9ff16002c9f76486cc3b433d3ebf378f71adf (patch)
tree05019af0da008da3ef6ae94a4beb636693530862 /sys-apps/inxi/inxi-2.3.8_p20170114.ebuild
parentdev-python/vcrpy: Version bump to 1.11.1 (diff)
downloadgentoo-9ba9ff16002c9f76486cc3b433d3ebf378f71adf.tar.gz
gentoo-9ba9ff16002c9f76486cc3b433d3ebf378f71adf.tar.bz2
gentoo-9ba9ff16002c9f76486cc3b433d3ebf378f71adf.zip
sys-apps/inxi: Version bump 2.3.8_p20170114
- cleaned ebuild - add dependency sys-apps/usbutils - more precise DESCRIPTION - unpack manpage .gz before doman Closes: https://github.com/gentoo/gentoo/pull/4777
Diffstat (limited to 'sys-apps/inxi/inxi-2.3.8_p20170114.ebuild')
-rw-r--r--sys-apps/inxi/inxi-2.3.8_p20170114.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/inxi/inxi-2.3.8_p20170114.ebuild b/sys-apps/inxi/inxi-2.3.8_p20170114.ebuild
new file mode 100644
index 000000000000..55d7955e7d3b
--- /dev/null
+++ b/sys-apps/inxi/inxi-2.3.8_p20170114.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_COMMIT=af0630e3067c138893e243896e1767c93d2a2856 #because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="The CLI inxi collects and prints hardware and system information"
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+ sys-apps/pciutils
+ sys-apps/usbutils
+ "
+S="${WORKDIR}/smxi-${PN}-${MY_COMMIT:0:7}"
+
+src_install() {
+ dobin "${PN}"
+ unpack "./${PN}.1.gz"
+ doman "${PN}.1"
+}