summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-14 12:24:07 +0100
committerSam James <sam@gentoo.org>2022-06-14 12:24:07 +0100
commitf7339b97d816c32ba4f9133bbd497963778eef1a (patch)
treee82bd8f36f28df99df11a1a78d70e4184e5fec28 /sys-apps/ethtool
parentmedia-libs/zxing-cpp: Stabilize 1.3.0 x86, #851828 (diff)
downloadgentoo-f7339b97d816c32ba4f9133bbd497963778eef1a.tar.gz
gentoo-f7339b97d816c32ba4f9133bbd497963778eef1a.tar.bz2
gentoo-f7339b97d816c32ba4f9133bbd497963778eef1a.zip
sys-apps/ethtool: add 5.18
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/ethtool')
-rw-r--r--sys-apps/ethtool/Manifest1
-rw-r--r--sys-apps/ethtool/ethtool-5.18.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/ethtool/Manifest b/sys-apps/ethtool/Manifest
index bc5cce260004..c51d14ff6424 100644
--- a/sys-apps/ethtool/Manifest
+++ b/sys-apps/ethtool/Manifest
@@ -3,3 +3,4 @@ DIST ethtool-5.14.tar.xz 318536 BLAKE2B 09b5c9c8103635e33b22e55caff3b0f3751bf14d
DIST ethtool-5.15.tar.xz 318864 BLAKE2B 855c07e388bfabf37637f20e2714c6ca27717f38d7f658be96e0e9ec9d4514e61f4ee29361fc0279510869606ad18126ccd2a47160f1097ab52b1e35216e9721 SHA512 28147468a92c179217b459907a3257ee4f2d2ed028cb87b074f1c7ca6eb91aca81c8a9f5c7fe74e81d16a516e6e7eb20137bf7a15b5479fd82a327c64954da12
DIST ethtool-5.16.tar.xz 320308 BLAKE2B 198d76502510e533b7f51785fd9f0848e840a6b4237bfd0496d005978ce3e638be02bd7dee971501f57c83354a1ac2f34a7ef29f2255764e900d9299bad9254c SHA512 9f0c24323b3144cbc6e684dc8c545a7c5e4804a061f10e32c937ea7420cc25c0891137fd4be4f1b9cf44907d8a59970ead9db424051ec5b4a90c225038f04025
DIST ethtool-5.17.tar.xz 321848 BLAKE2B 1695077d812b3ed8e287615d6a3aa15525a061110fa63563e4b2db3e5d4718b023415508db63e857c572fef248c6797564da596f17c80b833839899656840a5d SHA512 c9677829e3ed1f373bd993f72c710293a6e987bbd19829d437a436f42cf4e7995ee70a7db3590b1499ff6aa29c26815f4d0a3e4798ffb6992ae3f52b079cd3ff
+DIST ethtool-5.18.tar.xz 322600 BLAKE2B 5c06c74ac1453b66fa3f2a01a3face8c6483bdd6849a0b258f5a3d0c041712de4d628240843d09a54e69ec6256dfaac5fa3b08d5e1d2033b2810a01f9be04673 SHA512 bd53e64d5cfe0fe4c3fbc9ec84e64f77b72d0229bbb611575007fd1e4c5c13611440b292edc875f1916707477e1d1e19b8f46785285d6b88066e9b9aafba9753
diff --git a/sys-apps/ethtool/ethtool-5.18.ebuild b/sys-apps/ethtool/ethtool-5.18.ebuild
new file mode 100644
index 000000000000..8d122a733c09
--- /dev/null
+++ b/sys-apps/ethtool/ethtool-5.18.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Utility for examining and tuning ethernet-based network interfaces"
+HOMEPAGE="https://www.kernel.org/pub/software/network/ethtool/"
+SRC_URI="https://www.kernel.org/pub/software/network/ethtool/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+netlink"
+
+RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils"
+
+src_configure() {
+ econf $(use_enable netlink)
+}