summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2017-01-25 13:07:51 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2017-01-25 13:08:35 +0000
commit0dd83e11c9d80fd0f994dd1e9fdf1df012a81d9a (patch)
treeaad9e88e95b8469efcdd95f92b297a532c792329 /sys-apps/epoch/epoch-1.1.1.ebuild
parentapp-text/tesseract: restore ~mips keyword, as opencl USE flag is now masked (diff)
downloadgentoo-0dd83e11c9d80fd0f994dd1e9fdf1df012a81d9a.tar.gz
gentoo-0dd83e11c9d80fd0f994dd1e9fdf1df012a81d9a.tar.bz2
gentoo-0dd83e11c9d80fd0f994dd1e9fdf1df012a81d9a.zip
sys-apps/epoch: Removed old files
Package-Manager: portage-2.3.0
Diffstat (limited to 'sys-apps/epoch/epoch-1.1.1.ebuild')
-rw-r--r--sys-apps/epoch/epoch-1.1.1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/sys-apps/epoch/epoch-1.1.1.ebuild b/sys-apps/epoch/epoch-1.1.1.ebuild
deleted file mode 100644
index 65a09318efb2..000000000000
--- a/sys-apps/epoch/epoch-1.1.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils linux-info
-
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
-HOMEPAGE="http://universe2.us/epoch.html"
-SRC_URI="https://github.com/Subsentient/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_pretend() {
- local CONFIG_CHECK="~PROC_FS"
-
- [[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
-}
-
-src_compile() {
- NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
-}
-
-newepochins() {
- local type="$1"
-
- cd ${type} || die "Cannot change directory."
- for file in * ; do
- if [[ "${file}" != "epoch" ]] ; then
- new${type} ${file} epoch-${file}
- fi
- done
- cd .. || die "Cannot change directory."
-}
-
-src_install() {
- cd built || die "Cannot change directory."
-
- dosbin sbin/epoch
-
- # For now, rename to epoch-* until we can blend in with a standard approach.
- newepochins bin
- newepochins sbin
-
- insinto /etc/epoch/
- newins "${FILESDIR}"/${PN}-1.0_rc1-epoch.conf epoch.conf
-}
-
-pkg_postinst() {
- elog "Make sure to provide /run and /tmp tmpfs mounts using /etc/fstab."
- elog ""
- elog "An example epoch configuration is provided at /etc/epoch/epoch.conf"
- elog "which starts a minimal needed to use Gentoo."
- elog ""
- elog "To use epoch, add this kernel parameter: init=/usr/sbin/epoch-init"
- elog ""
- elog "Additional information about epoch is available at"
- elog "${HOMEPAGE} and configuration documentation at"
- elog "http://universe2.us/epochconfig.html which is useful reading material."
- elog ""
- elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
-}