summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/xd3d/xd3d-8.3.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/xd3d/xd3d-8.3.1.ebuild')
-rw-r--r--sci-visualization/xd3d/xd3d-8.3.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sci-visualization/xd3d/xd3d-8.3.1.ebuild b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
new file mode 100644
index 000000000000..124c85430504
--- /dev/null
+++ b/sci-visualization/xd3d/xd3d-8.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="Scientific visualization tool"
+HOMEPAGE="http://www.cmap.polytechnique.fr/~jouve/xd3d/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ app-shells/tcsh"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.diff \
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-rotated.patch \
+ "${FILESDIR}"/${P}-cflags.patch
+ sed \
+ -e 's:"zutil.h":<zlib.h>:g' \
+ -i src/qlib/timestuff.c || die
+}
+
+src_configure() {
+ tc-export CC
+ sed \
+ -e "s:##D##:${ED}:" \
+ -e "s:##lib##:$(get_libdir):" \
+ -i RULES.gentoo \
+ || die "failed to set up RULES.gentoo"
+ ./configure -arch=gentoo || die "configure failed."
+}
+
+src_install() {
+ dodir /usr/bin
+ emake install
+
+ dodoc BUGS CHANGELOG FAQ FORMATS README
+ insinto /usr/share/doc/${PF}
+ doins Manuals/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/
+ doins -r Examples
+ fi
+}