summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Freyermuth <o.freyermuth@googlemail.com>2020-04-19 17:42:35 +0200
committerGuilherme Amadio <amadio@gentoo.org>2020-05-20 14:37:26 +0200
commit5d089e2315b4f8020ca0698ffdeb97dd4f404704 (patch)
treee15f6a63504a0f94be7d787c9ea07b3ebb8cefc4 /sci-physics/vgm/vgm-9999.ebuild
parentsci-physics/vgm: Adapt SRC_URI and drop *-linux keywords (diff)
downloadgentoo-5d089e2315b4f8020ca0698ffdeb97dd4f404704.tar.gz
gentoo-5d089e2315b4f8020ca0698ffdeb97dd4f404704.tar.bz2
gentoo-5d089e2315b4f8020ca0698ffdeb97dd4f404704.zip
sci-physics/vgm: Bump to version 4.8
This adds c++11,c++14,c++17 flags and requires >=sci-physics/root-6.14 which also implements these switches. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Oliver Freyermuth <o.freyermuth@googlemail.com> Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/vgm/vgm-9999.ebuild')
-rw-r--r--sci-physics/vgm/vgm-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sci-physics/vgm/vgm-9999.ebuild b/sci-physics/vgm/vgm-9999.ebuild
index a6a93af9078e..5fba573e3f61 100644
--- a/sci-physics/vgm/vgm-9999.ebuild
+++ b/sci-physics/vgm/vgm-9999.ebuild
@@ -8,6 +8,7 @@ inherit cmake
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/vmc-project/${PN}.git"
+ KEYWORDS=""
else
MY_PV=$(ver_rs 1- -)
SRC_URI="https://github.com/vmc-project/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -20,13 +21,14 @@ HOMEPAGE="http://ivana.home.cern.ch/ivana/VGM.html"
LICENSE="GPL-2"
SLOT="0"
-IUSE="doc examples +geant4 +root test"
+IUSE="+c++11 c++14 c++17 doc examples +geant4 +root test"
+
+REQUIRED_USE="^^ ( c++11 c++14 c++17 )"
-# sci-physics/root[c++11] required to match sci-physics/geant
RDEPEND="
sci-physics/clhep:=
- root? ( sci-physics/root:=[c++11] )
- geant4? ( >=sci-physics/geant-4.10.03 )"
+ geant4? ( >=sci-physics/geant-4.10.6[c++11?,c++14?,c++17?] )
+ root? ( >=sci-physics/root-6.14:=[c++11?,c++14?,c++17?] )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen[dot] )
test? ( sci-physics/geant-vmc[g4root] )"