summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-11-26 10:43:50 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-11-26 10:44:12 +0100
commitcb54986d41de16df0fead12aa8323b130c81e01b (patch)
tree1bae657b0a41a6968329c5268d21293dacf237f3 /sci-mathematics/metamath/metamath-0.198.ebuild
parentdev-java/pdfbox: Stabilize 2.0.24 amd64, #824042 (diff)
downloadgentoo-cb54986d41de16df0fead12aa8323b130c81e01b.tar.gz
gentoo-cb54986d41de16df0fead12aa8323b130c81e01b.tar.bz2
gentoo-cb54986d41de16df0fead12aa8323b130c81e01b.zip
sci-mathematics/metamath: new package; add version 0.198
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/metamath/metamath-0.198.ebuild')
-rw-r--r--sci-mathematics/metamath/metamath-0.198.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-mathematics/metamath/metamath-0.198.ebuild b/sci-mathematics/metamath/metamath-0.198.ebuild
new file mode 100644
index 000000000000..4660a7b0656e
--- /dev/null
+++ b/sci-mathematics/metamath/metamath-0.198.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Proof verifier based on a minimalistic formalism"
+HOMEPAGE="http://us.metamath.org/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}-exe.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}-exe/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-exe-${PV}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/dont_force_optimize.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}