summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-02 09:12:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-02 09:12:41 +0000
commit7ab752f72e5d193ae65128b46367f59b3fcc610a (patch)
tree9e192fe8ceec23d99792a911d527f8940e71a548 /sci-libs
parentdev-python/peewee: Remove old (diff)
downloadgentoo-7ab752f72e5d193ae65128b46367f59b3fcc610a.tar.gz
gentoo-7ab752f72e5d193ae65128b46367f59b3fcc610a.tar.bz2
gentoo-7ab752f72e5d193ae65128b46367f59b3fcc610a.zip
sci-libs/geos: Bump
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/Manifest1
-rw-r--r--sci-libs/geos/geos-3.9.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/geos/Manifest b/sci-libs/geos/Manifest
index c486bce0963a..2c13200ecfac 100644
--- a/sci-libs/geos/Manifest
+++ b/sci-libs/geos/Manifest
@@ -1,2 +1,3 @@
DIST geos-3.8.1.tar.bz2 2505407 BLAKE2B 43053ea9e29d190f41c37d5d382b689ef477e0256cfd5705f4f2f316cac21a1674660bcf0900c51db72909c41d46be7a41d297958de48e108ae6d6bd1ca9d247 SHA512 1d8d8b3ece70eb388ea128f4135c7455899f01828223b23890ad3a2401e27104efce03987676794273a9b9d4907c0add2be381ff14b8420aaa9a858cc5941056
DIST geos-3.9.0-r1.tar.bz2 4710957 BLAKE2B dab0f4e0bfb1bd244c2faf5ee6149b65d142eea78e87490025f90b672eee0d25d4ba9bc4c3b223e78ea0c9d34625b4750c7ba03852e5ea9540ad5c479d84b995 SHA512 1081f2aa20e671450953f7bb53b17c703804a1c9f4987c9da0987ff24339af5811b2c8b79c8e438d04ca38e4d06164dc5a4206f266f7efc19af3f9d9ea8f71f8
+DIST geos-3.9.1-r1.tar.bz2 4761372 BLAKE2B af1597d9372b18a2f280d82941949518cd8edb9296e9647aa3949c9e10fdd1b6ef500298471ec469d711ab0569eabd8fc3fb0a8f7e9bd48f91150cfdcaea65a8 SHA512 7ea131685cd110ec5e0cb7c214b52b75397371e75f011e1410b6770b6a48ca492a02337d86a7be35c852ef94604fe9d6f49634c79d4946df611aaa4f5cbaee28
diff --git a/sci-libs/geos/geos-3.9.1.ebuild b/sci-libs/geos/geos-3.9.1.ebuild
new file mode 100644
index 000000000000..69116e672afc
--- /dev/null
+++ b/sci-libs/geos/geos-3.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="https://trac.osgeo.org/geos/"
+
+# Arrow can be removed at next version bump. Upstream mistakenly
+# released rc1 as 3.9.0. So, we need(ed) a new Manifest entry to get the
+# real 3.9.0
+SRC_URI="https://download.osgeo.org/geos/${PN}-${PV}.tar.bz2 -> ${PN}-${PV}-r1.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc static-libs"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+RESTRICT="test"
+
+src_configure() {
+ local myeconfargs=( $(use_enable static-libs static) )
+ use arm && myeconfargs+=( --disable-inline ) # bug 709368
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc doxygen-html
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/doxygen_docs/html/. )
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+}