summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/numbat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/numbat')
-rw-r--r--sci-chemistry/numbat/Manifest1
-rw-r--r--sci-chemistry/numbat/files/numbat-0.999-gnuplot.patch42
-rw-r--r--sci-chemistry/numbat/metadata.xml19
-rw-r--r--sci-chemistry/numbat/numbat-0.999-r1.ebuild53
4 files changed, 115 insertions, 0 deletions
diff --git a/sci-chemistry/numbat/Manifest b/sci-chemistry/numbat/Manifest
new file mode 100644
index 000000000000..6c26ed4a268f
--- /dev/null
+++ b/sci-chemistry/numbat/Manifest
@@ -0,0 +1 @@
+DIST Numbat-0.999.tar.gz 1791471 SHA256 aef72903f262c5a25e542429f3cc7aca4d2dbc920c08b59847d5cb325855e9ab SHA512 0887f77905bbb476b0d12a7015d5d5745023740acc974ea9cd452de7d38a75a92e6090015127588b38ba62353d38c2be20f57be5df3011b51050c4934dfd206c WHIRLPOOL 8282bf5481a93d17a833f809c28d927d681d6d5016552a07b9267bdb78e99fc568370321567d7d6a87a84f31eea8fae9494c1ae8c0109157fca779c7c06805d9
diff --git a/sci-chemistry/numbat/files/numbat-0.999-gnuplot.patch b/sci-chemistry/numbat/files/numbat-0.999-gnuplot.patch
new file mode 100644
index 000000000000..942f5871e50b
--- /dev/null
+++ b/sci-chemistry/numbat/files/numbat-0.999-gnuplot.patch
@@ -0,0 +1,42 @@
+ src/error_analysis.c | 20 ++++++++++----------
+ 1 file changed, 10 insertions(+), 10 deletions(-)
+
+diff --git a/src/error_analysis.c b/src/error_analysis.c
+index eb86a6f..c0edf5f 100644
+--- a/src/error_analysis.c
++++ b/src/error_analysis.c
+@@ -848,11 +848,11 @@ void write_sanson_mac(FILE * F, char * name_plot, char * name_world, int number_
+ }
+
+ fprintf(F, "reset\n");
+- fprintf(F, "set noxtics\n");
+- fprintf(F, "set noytics\n");
++ fprintf(F, "unset xtics\n");
++ fprintf(F, "unset ytics\n");
+ fprintf(F, "set angles degrees\n");
+- fprintf(F, "set nogrid\n");
+- fprintf(F, "set noborder\n");
++ fprintf(F, "unset grid\n");
++ fprintf(F, "unset border\n");
+ //fprintf(F, "width=40\n");
+ //fprintf(F, "height=width*(3./4.)\n");
+ //fprintf(F, "set xrange [-width : width]\n");
+@@ -867,12 +867,12 @@ void write_sanson_mac(FILE * F, char * name_plot, char * name_world, int number_
+ fprintf(F, "YC(lat,lon)=(lon-long0)*cos(lat)\n");
+ fprintf(F, "plot '%s' using (YC($2,$1)):(XC($2,$1)) t '' with lines lw 0.1 lt -1", name_world);
+ for(i = 0; i < number_of_tensor; i++){
+- fprintf(F, ", '%s' using (YC($%d,$%d)):(XC($%d,$%d)) t '' with points %d", name_plot,
+- 6*i+2, 6*i+1, 6*i+2, 6*i+1, 3*i+1);
+- fprintf(F, ", '%s' using (YC($%d,$%d)):(XC($%d,$%d)) t '' with points %d", name_plot,
+- 6*i+4, 6*i+3, 6*i+4, 6*i+3, 3*i+2);
+- fprintf(F, ", '%s' using (YC($%d,$%d)):(XC($%d,$%d)) t '' with points %d", name_plot,
+- 6*i+6, 6*i+5, 6*i+6, 6*i+5, 3*i+3);
++ fprintf(F, ", '%s' using (YC($%d,$%d)):(XC($%d,$%d)) t '' with points", name_plot,
++ 6*i+2, 6*i+1, 6*i+2, 6*i+1);
++ fprintf(F, ", '%s' using (YC($%d,$%d)):(XC($%d,$%d)) t '' with points", name_plot,
++ 6*i+4, 6*i+3, 6*i+4, 6*i+3);
++ fprintf(F, ", '%s' using (YC($%d,$%d)):(XC($%d,$%d)) t '' with points", name_plot,
++ 6*i+6, 6*i+5, 6*i+6, 6*i+5);
+ }
+ fprintf(F, "\n");
+ //fprintf(F, "pause 2\n");
diff --git a/sci-chemistry/numbat/metadata.xml b/sci-chemistry/numbat/metadata.xml
new file mode 100644
index 000000000000..054dc8435cf6
--- /dev/null
+++ b/sci-chemistry/numbat/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Numbat is a user friendly software that fits dX-tensor to a set of PCS
+measurements and a structure from a PDB file. It has also been designed to
+assist in the semi automatic process of PCS assignment. A detailed description
+of the software can be found in this publication:
+
+Christophe Schmitz, Mitchell J. Stanton-Cook, Xun-Cheng Su, Gottfried Otting,
+and Thomas Huber (2008). Numbat: an interactive software tool for fitting
+Δχ-tensors to molecular coordinates using pseudocontact shifts. Journal of
+Biomolecular NMR. 41:179-189.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/numbat/numbat-0.999-r1.ebuild b/sci-chemistry/numbat/numbat-0.999-r1.ebuild
new file mode 100644
index 000000000000..c34f931aa5b1
--- /dev/null
+++ b/sci-chemistry/numbat/numbat-0.999-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+MY_PN="Numbat"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="new user-friendly method built for automatic dX-tensor determination"
+HOMEPAGE="http://www.nmr.chem.uu.nl/~christophe/numbat.html"
+SRC_URI="http://comp-bio.anu.edu.au/private/downloads/Numbat/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CDEPEND="
+ gnome-base/libglade:2.0
+ sci-libs/gsl
+ x11-libs/gtk+:2"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ sci-chemistry/molmol
+ sci-chemistry/pymol
+ sci-visualization/gnuplot"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=(
+# "${FILESDIR}"/${P}-glade.patch
+ "${FILESDIR}"/${P}-gnuplot.patch )
+
+src_prepare() {
+ sed \
+ -e '/COPYING/d' \
+ -e "s:doc/numbat:share/doc/${PF}:g" \
+ -i Makefile.am src/common.h || die
+ rm missing
+ emake distclean
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ autotools-utils_src_install
+}