summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-23 22:13:26 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-23 22:21:44 -0500
commit0eb041dad18453b6da49dac399cbea824d1a9549 (patch)
tree5b762a1ae0760e3b926c9a45bf55db9ce69ba540 /sci-chemistry/molden/molden-4.8-r2.ebuild
parentsci-chemistry/ksdssp: drop old (diff)
downloadgentoo-0eb041dad18453b6da49dac399cbea824d1a9549.tar.gz
gentoo-0eb041dad18453b6da49dac399cbea824d1a9549.tar.bz2
gentoo-0eb041dad18453b6da49dac399cbea824d1a9549.zip
sci-chemistry/molden: drop old EAPI
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'sci-chemistry/molden/molden-4.8-r2.ebuild')
-rw-r--r--sci-chemistry/molden/molden-4.8-r2.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/sci-chemistry/molden/molden-4.8-r2.ebuild b/sci-chemistry/molden/molden-4.8-r2.ebuild
deleted file mode 100644
index f00761130395..000000000000
--- a/sci-chemistry/molden/molden-4.8-r2.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils fortran-2 flag-o-matic toolchain-funcs
-
-MY_P="${PN}${PV}"
-
-DESCRIPTION="Display molecular density from GAMESS-UK, GAMESS-US, GAUSSIAN and Mopac/Ampac"
-HOMEPAGE="http://www.cmbi.ru.nl/molden/"
-SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molgraph/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MOLDEN"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="opengl"
-
-RDEPEND="
- x11-libs/libXmu
- virtual/glu
- opengl? (
- media-libs/freeglut
- virtual/opengl )"
-DEPEND="${RDEPEND}
- x11-misc/gccmakedep
- app-editors/vim"
- # vim provides ex, which the build system uses (surf/Makefile, at least)
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-ambfor.patch \
- "${FILESDIR}"/${P}-overflow.patch \
- "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${PN}-4.7-implicit-dec.patch
- sed \
- -e 's:makedepend:gccmakedep:g' \
- -e "s:/usr/include/sgidefs.h::g" \
- -i surf/Makefile || die
- sed 's:shell g77:shell $(FC):g' -i makefile || die
-}
-
-src_compile() {
- # Use -mieee on alpha, according to the Makefile
- use alpha && append-flags -mieee
-
- # Honor CC, CFLAGS, FC, and FFLAGS from environment;
- # unfortunately a bash bug prevents us from doing typeset and
- # assignment on the same line.
- typeset -a args
- args=(
- CC="$(tc-getCC) ${CFLAGS}" \
- FC="$(tc-getFC)" \
- LDR="$(tc-getFC)" \
- FFLAGS="${FFLAGS}" )
-
- einfo "Building Molden..."
- emake -j1 "${args[@]}"
- if use opengl ; then
- einfo "Building Molden OpenGL helper..."
- emake -j1 "${args[@]}" moldenogl
- fi
-}
-
-src_install() {
- dobin ${PN} g${PN}
- if use opengl ; then
- dobin ${PN}ogl
- fi
-
- dodoc HISTORY README REGISTER
- cd doc
- uncompress * && dodoc *
-}