summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/easychem
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/easychem')
-rw-r--r--sci-chemistry/easychem/Manifest1
-rw-r--r--sci-chemistry/easychem/easychem-0.6-r1.ebuild40
-rw-r--r--sci-chemistry/easychem/files/0.6-gentoo.patch65
-rw-r--r--sci-chemistry/easychem/files/easychem-0.6-prestrip.patch10
-rw-r--r--sci-chemistry/easychem/metadata.xml15
5 files changed, 131 insertions, 0 deletions
diff --git a/sci-chemistry/easychem/Manifest b/sci-chemistry/easychem/Manifest
new file mode 100644
index 000000000000..8c12b1a64218
--- /dev/null
+++ b/sci-chemistry/easychem/Manifest
@@ -0,0 +1 @@
+DIST easychem-0.6.tar.gz 265458 SHA256 1dba1a1ed1862c723cd77184a90ee7571a26ebcb0d3c22e7e032af1cbafe284d SHA512 83f877d1813287592a460f4dc3769feda88e45d8f77cd728c4055b60521babe253b4432033941ff429c753cfe675a642714052a01736534147398d6972e47051 WHIRLPOOL 7869025a921b2a6ada516f60c3e79247b1ad74a0bb904f7dd9b7bd993b3b5166ccd3f266f6c2e85198c8bde1ddaf863518a7adea7a6fd9b22bf789e1df7103fe
diff --git a/sci-chemistry/easychem/easychem-0.6-r1.ebuild b/sci-chemistry/easychem/easychem-0.6-r1.ebuild
new file mode 100644
index 000000000000..932cf7709daa
--- /dev/null
+++ b/sci-chemistry/easychem/easychem-0.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Chemical structure drawing program - focused on presentation"
+HOMEPAGE="http://easychem.sourceforge.net/"
+SRC_URI="mirror://sourceforge/easychem/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gtk+:2
+ app-text/ghostscript-gpl
+ media-gfx/pstoedit"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_compile() {
+ ln -s Makefile.linux Makefile || die
+ DGS_PATH="${EPREFIX}"/usr/bin DPSTOEDIT_PATH="${EPREFIX}"/usr/bin \
+ C_FLAGS="${CFLAGS}" emake -e
+}
+
+src_install () {
+ dobin easychem
+ dodoc TODO
+}
diff --git a/sci-chemistry/easychem/files/0.6-gentoo.patch b/sci-chemistry/easychem/files/0.6-gentoo.patch
new file mode 100644
index 000000000000..000e4373b3c2
--- /dev/null
+++ b/sci-chemistry/easychem/files/0.6-gentoo.patch
@@ -0,0 +1,65 @@
+diff --git a/Makefile.linux b/Makefile.linux
+index 6638394..5da56b0 100644
+--- a/Makefile.linux
++++ b/Makefile.linux
+@@ -1,5 +1,5 @@
+ # The C compiler
+-CC=gcc
++CC ?= gcc
+
+ # The following line must be uncommented if you want to specify a place
+ # where the 'gs' (or 'pstoedit') program is.
+@@ -25,11 +25,10 @@ GTK_LIBS=`pkg-config --libs gtk+-2.0`
+ # The list of important files
+ OBJECTS=auxi.o bonds.o easychem.o export.o dialogs.o detect.o library.o drawing.o
+
+-all: easychem po/
++all: easychem po
+
+-easychem: postscript/ graph/ $(OBJECTS)
+- $(CC) -o easychem $(OBJECTS) $(GTK_LIBS) $(C_FLAGS)
+- strip easychem
++easychem: postscript graph $(OBJECTS)
++ $(CC) $(C_FLAGS) $(LDFLAGS) -o easychem $(OBJECTS) $(GTK_LIBS) -lm
+
+ clean: FORCE
+ -cd graph; make clean
+@@ -37,7 +36,7 @@ clean: FORCE
+ -cd po; make clean
+ -rm $(OBJECTS) easychem
+
+-export.o: export.c common.h bonds.h postscript/
++export.o: export.c common.h bonds.h postscript
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c export.c
+ bonds.o: bonds.c common.h bonds.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c bonds.c
+@@ -49,20 +48,22 @@ library.o: library.c common.h library.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c library.c
+ drawing.o: drawing.c common.h drawing.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c drawing.c
+-dialogs.o: dialogs.c common.h dialogs.h graph/
++dialogs.o: dialogs.c common.h dialogs.h graph
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c dialogs.c
+ detect.o: detect.c common.h detect.h
+ $(CC) $(GTK_FLAGS) $(C_FLAGS) -c detect.c
+
+ # The rules for subdirectories
+-graph/: FORCE
+- cd graph; make all
++graph:
++ +make -C $@
+
+-postscript/: FORCE
+- cd postscript; make all
++postscript:
++ +make -C $@
+
+-po/: FORCE
+- cd po; make all
++po:
++ +make -C $@
+
+ # This is used to force an update
+ FORCE:
++
++.PHONY: graph postscript po
diff --git a/sci-chemistry/easychem/files/easychem-0.6-prestrip.patch b/sci-chemistry/easychem/files/easychem-0.6-prestrip.patch
new file mode 100644
index 000000000000..a1cbbb055d0c
--- /dev/null
+++ b/sci-chemistry/easychem/files/easychem-0.6-prestrip.patch
@@ -0,0 +1,10 @@
+--- Makefile.linux.orig 2009-02-23 21:17:25.000000000 +0200
++++ Makefile.linux 2009-02-23 21:17:50.000000000 +0200
+@@ -29,7 +29,6 @@
+
+ easychem: postscript/ graph/ $(OBJECTS)
+ $(CC) -o easychem $(OBJECTS) $(GTK_LIBS) $(C_FLAGS)
+- strip easychem
+
+ clean: FORCE
+ -cd graph; make clean
diff --git a/sci-chemistry/easychem/metadata.xml b/sci-chemistry/easychem/metadata.xml
new file mode 100644
index 000000000000..0a2ea04beeec
--- /dev/null
+++ b/sci-chemistry/easychem/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <longdescription>
+ EasyChem is a program designed to draw chemical molecules, written under
+ Linux using Gtk+ 2.4. It is implemented with a strong focus on producing
+ press quality molecules. Easychem can be a little more difficult to learn to
+ use, but when mastered it can be very fast and powerful. It can draw
+ ornaments easily, and exports to EPS with LaTeX fonts among other things.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">easychem</remote-id>
+ </upstream>
+</pkgmetadata>