summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 18:32:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 18:34:30 +0200
commit3ea6a505ae3bfa74715b81a5ef39b726cc4abbe7 (patch)
tree1a07574773d8054b223626912955a42e3a3bdd73 /sci-biology/fasttree/fasttree-2.1.8.ebuild
parentsci-biology/express: Drop old (diff)
downloadgentoo-3ea6a505ae3bfa74715b81a5ef39b726cc4abbe7.tar.gz
gentoo-3ea6a505ae3bfa74715b81a5ef39b726cc4abbe7.tar.bz2
gentoo-3ea6a505ae3bfa74715b81a5ef39b726cc4abbe7.zip
sci-biology/fasttree: Drop 2.1.7
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sci-biology/fasttree/fasttree-2.1.8.ebuild')
-rw-r--r--sci-biology/fasttree/fasttree-2.1.8.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sci-biology/fasttree/fasttree-2.1.8.ebuild b/sci-biology/fasttree/fasttree-2.1.8.ebuild
index 7df71ee4474d..3f9e4ad5f759 100644
--- a/sci-biology/fasttree/fasttree-2.1.8.ebuild
+++ b/sci-biology/fasttree/fasttree-2.1.8.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit cmake-utils
@@ -39,9 +39,9 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DVERSION="${PV}"
- $(cmake-utils_use_has cpu_flags_x86_sse3 sse3)
- $(cmake-utils_use_use openmp)
- $(cmake-utils_use_use double-precision double)
+ -DHAS_SSE3=$(usex cpu_flags_x86_sse3)
+ -DUSE_OPENMP=$(usex openmp)
+ -DUSE_DOUBLE=$(usex double-precision)
)
cmake-utils_src_configure
}