summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-10-17 12:49:08 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-10-17 12:53:27 -0500
commitc048b92a768909e1b007b5e8d6cc0bd54a64a1b1 (patch)
tree8e6a70729eca2e2aa91011ce5686a1ba057a5607 /net-vpn
parentx11-drivers/nvidia-drivers: add 545.23.06 (unkeyworded NFB beta) (diff)
downloadgentoo-c048b92a768909e1b007b5e8d6cc0bd54a64a1b1.tar.gz
gentoo-c048b92a768909e1b007b5e8d6cc0bd54a64a1b1.tar.bz2
gentoo-c048b92a768909e1b007b5e8d6cc0bd54a64a1b1.zip
net-vpn/tailscale: add 1.50.1
Closes: https://bugs.gentoo.org/915633 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tailscale/Manifest2
-rw-r--r--net-vpn/tailscale/tailscale-1.50.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/net-vpn/tailscale/Manifest b/net-vpn/tailscale/Manifest
index 236948aaef8c..e276649c3319 100644
--- a/net-vpn/tailscale/Manifest
+++ b/net-vpn/tailscale/Manifest
@@ -4,3 +4,5 @@ DIST tailscale-1.38.4-deps.tar.xz 252299404 BLAKE2B aa500af08c64dd07dc04b4f96d8c
DIST tailscale-1.38.4.tar.gz 1644918 BLAKE2B e61c32513afe8715b99e5ee14ee572849fd1b92c31744894af4d028ab599685d2e38c5fb6eb9e8d40e0638d427065499089152ae002ef7dc947d3957f0fdc785 SHA512 f077217d9333263f3883d766abfb8a9adef3cf9c06544cca28bca41e6f51bf06991a0d31ff2ec0dbf01e80cbc04c903bb5b55cdcd871269d3b659664ce24d011
DIST tailscale-1.46.1-deps.tar.xz 370535596 BLAKE2B 84c37e83f6ced653132c9a3639ad652cf258ab232d7f32fd5fbe8d2303aaae87c169bc6948c602be435f88c05373c6908d2120b16b83fc3795230fd633a62add SHA512 358a91bdff4df7933660a31f0c967e090c8b10b42abf3e6497bf163e93bf86e4b98b5defadf5dba87815c941361310bfde6060927da73eac0bb55f56c80dace2
DIST tailscale-1.46.1.tar.gz 1817180 BLAKE2B b5ace1aa3fa98b14be53bbf55ec271cbbaf4c28a095300963961dd8bc5ee308091d46807af3b82f8ecb88070763a245292304706ab29e74d6f1e56ff495c2c51 SHA512 cecaa216b1f451b65e826856f630e5dd8ef9bbd85684602450e71f0f46b6b1b97bf20a0b7c401a72c354a5a9404386d6bd03350da2a65fb4e358320763d93ab4
+DIST tailscale-1.50.1-deps.tar.xz 371484616 BLAKE2B cb4ac1939c4ad36bf3c752ccbdd1f34469e96e0576ae0f4bdede2f6e8ce8865c17addaead22c3be862846b1b9399900c0f3c8c0d720c5200c35405a974c85ec8 SHA512 3f11ba62e9879c0e51cd76a6e524d5e6bacb101e26e700872507f08c7924147a146a56933cd391a2b845bfb4fc7ad31a0a13dbc21dd3c8a2f7e10feea6d8b926
+DIST tailscale-1.50.1.tar.gz 1992569 BLAKE2B 503dd358d13f038eafd67d2c00f292965eaba390ec483daded893082a87428c4bbf01bafb0339aaca3ebc62123985f0686046959d4aa25325b877a779de83b34 SHA512 3eb0e0f0ef6df4d77f9649fb8deb8b829286bc8ab70016b09da6aad9aa4e5d027494e2151db425b52e775997345d39d13bce6013e8c69700023a936f142dcfd6
diff --git a/net-vpn/tailscale/tailscale-1.50.1.ebuild b/net-vpn/tailscale/tailscale-1.50.1.ebuild
new file mode 100644
index 000000000000..0c73b128412b
--- /dev/null
+++ b/net-vpn/tailscale/tailscale-1.50.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# These settings are obtained by running ./build_dist.sh shellvars` in
+# the upstream repo.
+VERSION_MINOR="50"
+VERSION_SHORT="1.50.1"
+VERSION_LONG="1.50.1-t874938806"
+VERSION_GIT_HASH="8749388061d0251483389fa876afa01e0e76f15b"
+
+DESCRIPTION="Tailscale vpn client"
+HOMEPAGE="https://tailscale.com"
+SRC_URI="https://github.com/tailscale/tailscale/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="net-firewall/iptables"
+
+RESTRICT="test"
+
+# This translates the build command from upstream's build_dist.sh to an
+# ebuild equivalent.
+build_dist() {
+ ego build -tags xversion -ldflags "
+ -X tailscale.com/version.Long=${VERSION_LONG}
+ -X tailscale.com/version.Short=${VERSION_SHORT}
+ -X tailscale.com/version.GitCommit=${VERSION_GIT_HASH}" "$@"
+}
+
+src_compile() {
+ build_dist ./cmd/tailscale
+ build_dist ./cmd/tailscaled
+}
+
+src_install() {
+ dosbin tailscaled
+ dobin tailscale
+
+ systemd_dounit cmd/tailscaled/tailscaled.service
+ insinto /etc/default
+ newins cmd/tailscaled/tailscaled.defaults tailscaled
+ keepdir /var/lib/${PN}
+ fperms 0750 /var/lib/${PN}
+
+ newtmpfiles "${FILESDIR}/${PN}.tmpfiles" ${PN}.conf
+
+ newinitd "${FILESDIR}/${PN}d.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}d.confd" ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+}