summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/yaggui
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/yaggui')
-rw-r--r--net-p2p/yaggui/Manifest1
-rw-r--r--net-p2p/yaggui/files/yaggui.sh19
-rw-r--r--net-p2p/yaggui/metadata.xml9
-rw-r--r--net-p2p/yaggui/yaggui-0.9.2.ebuild44
4 files changed, 73 insertions, 0 deletions
diff --git a/net-p2p/yaggui/Manifest b/net-p2p/yaggui/Manifest
new file mode 100644
index 000000000000..0cd60c8c8d50
--- /dev/null
+++ b/net-p2p/yaggui/Manifest
@@ -0,0 +1 @@
+DIST Yaggui-src-0.9.2.zip 297601 SHA256 21e2f3176bf73c851dd2359a862c48dcd318ae3babacf1bbfde71ea3e29ad130
diff --git a/net-p2p/yaggui/files/yaggui.sh b/net-p2p/yaggui/files/yaggui.sh
new file mode 100644
index 000000000000..7b7c89b43cbc
--- /dev/null
+++ b/net-p2p/yaggui/files/yaggui.sh
@@ -0,0 +1,19 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+if [ ! "$(ps -A | grep -e giftd)" ]
+then
+ echo "Error! Unable to find giFT daemon!"
+ echo "Attempting to start the giFT daemon..."
+ giftd > /dev/null &
+ if [ ! "$(ps -A | grep -e giftd)" ]
+ then
+ echo "Could not start the giFT daemon! Continuing to load Yaggui..."
+ else
+ echo "giFT daemon started, continuing to load Yaggui..."
+ fi
+fi
+
+java -jar /usr/share/yaggui/lib/Yaggui.jar
diff --git a/net-p2p/yaggui/metadata.xml b/net-p2p/yaggui/metadata.xml
new file mode 100644
index 000000000000..1e659b751970
--- /dev/null
+++ b/net-p2p/yaggui/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">yaggui</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/yaggui/yaggui-0.9.2.ebuild b/net-p2p/yaggui/yaggui-0.9.2.ebuild
new file mode 100644
index 000000000000..8cc085e1b331
--- /dev/null
+++ b/net-p2p/yaggui/yaggui-0.9.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="Yet Another Gift GUI in java"
+HOMEPAGE="http://yaggui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yaggui/${MY_P/y/Y}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+COMMON_DEP="=dev-java/jgoodies-looks-1.2*"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+
+EANT_BUILD_TARGET="build-jar"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -e '/<unzip/d' -i build.xml || die
+ rm -v lib/*.jar || die
+ java-pkg_jar-from jgoodies-looks-1.2 looks.jar lib/plastic-1.1.2.jar
+ java-pkg_filter-compiler jikes
+}
+
+src_install() {
+ java-pkg_newjar build/Yaggui.jar
+
+ java-pkg_dolauncher ${PN} --main de.hampelratte.yaggui.Main
+
+ dodoc doc/{changelog,Readme.txt} || die
+}