summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2021-09-10 13:00:58 +0300
committerSergey Popov <pinkbyte@gentoo.org>2021-09-10 13:05:41 +0300
commit24e95848dce251d82e02054b325624ea69714cc4 (patch)
treeb6367e3206c99744a2dcd62583915c62b13b7125 /net-news/canto-daemon/canto-daemon-0.9.8.ebuild
parentnet-mail/courier-imap: bump 5.1.4 (diff)
downloadgentoo-24e95848dce251d82e02054b325624ea69714cc4.tar.gz
gentoo-24e95848dce251d82e02054b325624ea69714cc4.tar.bz2
gentoo-24e95848dce251d82e02054b325624ea69714cc4.zip
net-news/canto-daemon: version bump, add Python 3.9 support
Fix incorrect DISTUTILS_USE_SETUPTOOLS Closes: https://bugs.gentoo.org/809458 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'net-news/canto-daemon/canto-daemon-0.9.8.ebuild')
-rw-r--r--net-news/canto-daemon/canto-daemon-0.9.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-news/canto-daemon/canto-daemon-0.9.8.ebuild b/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
new file mode 100644
index 000000000000..e9126d4bcac8
--- /dev/null
+++ b/net-news/canto-daemon/canto-daemon-0.9.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="xml(+),threads(+)"
+inherit distutils-r1 multilib
+
+DESCRIPTION="Daemon part of Canto-NG RSS reader"
+HOMEPAGE="https://codezen.org/canto-ng/"
+SRC_URI="https://github.com/themoken/canto-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/feedparser[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/canto-next-${PV}"
+
+python_prepare_all() {
+ # Respect libdir during plugins installation
+ sed -i -e "s:lib/canto:$(get_libdir)/canto:" setup.py || die
+
+ distutils-r1_python_prepare_all
+}