summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-05 01:31:43 -0400
committerSam James <sam@gentoo.org>2024-05-05 12:47:14 +0100
commit6e5275a457f8a91e08ab8ea24a546866fcfad1d6 (patch)
treefe1d3d7618973e075c25ff1f25be209f2f129b9c /net-misc
parentnet-irc/weechat: implement new option in live ebuild (diff)
downloadgentoo-6e5275a457f8a91e08ab8ea24a546866fcfad1d6.tar.gz
gentoo-6e5275a457f8a91e08ab8ea24a546866fcfad1d6.tar.bz2
gentoo-6e5275a457f8a91e08ab8ea24a546866fcfad1d6.zip
net-misc/nx: mark as LTO-unsafe, strict-aliasing unsafe
It's code vendored from xorg, so nothing to fix. xorg already sets this, so doing it here is just attaining parity anyway. Closes: https://bugs.gentoo.org/861680 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nx/nx-3.5.99.26.ebuild11
-rw-r--r--net-misc/nx/nx-3.5.99.27.ebuild11
2 files changed, 18 insertions, 4 deletions
diff --git a/net-misc/nx/nx-3.5.99.26.ebuild b/net-misc/nx/nx-3.5.99.26.ebuild
index 01e20ce031b4..3a112d2be6bb 100644
--- a/net-misc/nx/nx-3.5.99.26.ebuild
+++ b/net-misc/nx/nx-3.5.99.26.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="NX compression technology core libraries"
HOMEPAGE="https://github.com/ArcticaProject/nx-libs"
@@ -72,6 +72,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861680
+ #
+ # inherited from libX11 vendored code. libX11 passes this flag already.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# From xorg-x11-6.9.0-r3.ebuild
pushd nx-X11 || die
HOSTCONF="config/cf/host.def"
diff --git a/net-misc/nx/nx-3.5.99.27.ebuild b/net-misc/nx/nx-3.5.99.27.ebuild
index e054f77bb1e5..60a90c7c8d28 100644
--- a/net-misc/nx/nx-3.5.99.27.ebuild
+++ b/net-misc/nx/nx-3.5.99.27.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
DESCRIPTION="NX compression technology core libraries"
HOMEPAGE="https://github.com/ArcticaProject/nx-libs"
@@ -66,6 +66,13 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/861680
+ #
+ # inherited from libX11 vendored code. libX11 passes this flag already.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
# From xorg-x11-6.9.0-r3.ebuild
pushd nx-X11 || die
HOSTCONF="config/cf/host.def"