summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNHOrus <jy6x2b32pie9@yahoo.com>2024-04-04 21:28:31 +0400
committerSam James <sam@gentoo.org>2024-05-08 12:09:24 +0100
commit4194a4063d57fe433e58016d40f81fb0a1e6377e (patch)
tree9cb03786a45bc25d6d8162cc1702d4899923caa3 /net-misc
parentx11-libs/wxGTK: remove auto_ptr in 3.0.5.1 (diff)
downloadgentoo-4194a4063d57fe433e58016d40f81fb0a1e6377e.tar.gz
gentoo-4194a4063d57fe433e58016d40f81fb0a1e6377e.tar.bz2
gentoo-4194a4063d57fe433e58016d40f81fb0a1e6377e.zip
net-misc/vrrpd: add 1.15
New version doesn't contain compilation failures [sam: Don't drop 1.9 in the same commit. Keep it around in case of regressions.] Closes: https://bugs.gentoo.org/874432 Closes: https://bugs.gentoo.org/831387 Signed-off-by: NHOrus <jy6x2b32pie9@yahoo.com> Closes: https://github.com/gentoo/gentoo/pull/36104 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vrrpd/Manifest1
-rw-r--r--net-misc/vrrpd/metadata.xml2
-rw-r--r--net-misc/vrrpd/vrrpd-1.15.ebuild41
3 files changed, 43 insertions, 1 deletions
diff --git a/net-misc/vrrpd/Manifest b/net-misc/vrrpd/Manifest
index 9a753e86eb47..e2a5edf9135c 100644
--- a/net-misc/vrrpd/Manifest
+++ b/net-misc/vrrpd/Manifest
@@ -1 +1,2 @@
+DIST vrrpd-1.15.tar.gz 166691 BLAKE2B 610704926ee7b24cdc22030b135f3dd7ee61f6f2b291c8695781f0f0948d89efbe7bd5f0b25a71124b0a1818967a0c1ef8c2516c94f14c9a3903eb78e75537e4 SHA512 3ec867002c9d0d72f96f6b3d4fbeef074f31951449ec49818dd992691623b8265d97865fad39f77787cfbc27d485c95617f8b9f47dd026908ebad27fb06f9f69
DIST vrrpd-1.9.tar.gz 542249 BLAKE2B a412559be70791515c6b82639a8e1d5fc33954963fbf00aa3c549434ac0748b9d0ea657b2d02b1a3537a30742c18fe6d6db832a11c23b6989151c5f04c771d05 SHA512 8c719cabbd6a799e4e439dbb698af9d6e24cf2635cfbd71a204b46bd2b65c1384e53f130b663d0fcfc903d89080ff25d9c97ae4cd9f6b2434d5462cf678a306b
diff --git a/net-misc/vrrpd/metadata.xml b/net-misc/vrrpd/metadata.xml
index f1c67d2187e4..ee849f0e1dd3 100644
--- a/net-misc/vrrpd/metadata.xml
+++ b/net-misc/vrrpd/metadata.xml
@@ -6,7 +6,7 @@
<name>Robin H. Johnson</name>
</maintainer>
<upstream>
- <remote-id type="github">fredbcode/Vrrpd</remote-id>
+ <remote-id type="gitlab">fredbcode/Vrrpd</remote-id>
<remote-id type="sourceforge">vrrpd</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-misc/vrrpd/vrrpd-1.15.ebuild b/net-misc/vrrpd/vrrpd-1.15.ebuild
new file mode 100644
index 000000000000..967b17a748f1
--- /dev/null
+++ b/net-misc/vrrpd/vrrpd-1.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Virtual Router Redundancy Protocol Daemon"
+HOMEPAGE="https://gitlab.com/fredbcode/Vrrpd/"
+GITLAB_SHA1="a318281271973c7430cfa520b540585153454c4b"
+SRC_URI="https://gitlab.com/fredbcode/Vrrpd/-/archive/v${PV}/${P}.tar.gz"
+
+S="${WORKDIR}/Vrrpd-v${PV}-${GITLAB_SHA1}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ # Don't hardcore GCC
+ sed -e '/CC=/d' -i Makefile || die
+
+ emake mrproper
+}
+
+src_compile() {
+ local myemakeargs=(
+ DBG_OPT=""
+ MACHINEOPT="${CFLAGS}"
+ PROF_OPT="${LDFLAGS}"
+ )
+
+ emake "${myemakeargs[@]}"
+}
+
+src_install() {
+ dosbin vrrpd atropos
+ doman vrrpd.8
+ dodoc FAQ Changes TODO scott_example README.md
+ dodoc doc/*
+}