summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-16 19:14:44 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-16 19:20:27 -0400
commite73dce6e0195483677ae7f717fd15a805ad45a0e (patch)
tree0eda9b0d58ba39ac687a64f22cf0979e2aee356a /net-misc
parentapp-containers/cosign: add 2.2.4 (diff)
downloadgentoo-e73dce6e0195483677ae7f717fd15a805ad45a0e.tar.gz
gentoo-e73dce6e0195483677ae7f717fd15a805ad45a0e.tar.bz2
gentoo-e73dce6e0195483677ae7f717fd15a805ad45a0e.zip
net-misc/yt-dlp: add 2024.07.16
Well, if releases are going to be that frequent from now on, may just always do straight-to-stable even without a specific reason to unless there are major potentially breaking changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2024.07.16.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index 002c3131a12f..06ff47432bc6 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1,2 +1,3 @@
DIST yt-dlp-2024.07.07.tar.gz 5687365 BLAKE2B 877b8bd15d7650b0afa928f44bac587843d1e37b8f26b82a64af9171525a26f89930b40f5f24e8c81833220bf78da4669bea0e4a660211a673e6209e9e062f07 SHA512 f6cb892db1364ccce2c2f99c5b0cb859475cd7757c93f03e1059c8222aadf2fd2220c6ea3509334a16439858274bbeb889dce52d7a9158043d6de473d5346598
DIST yt-dlp-2024.07.09.tar.gz 5689089 BLAKE2B c5f6c17b68ad1816af5c1ae480afd9ba6300a7b588d44a86d780433f147dbf12a1598c4940907277d9fcbd3d924616460c1ea98b8b84ebe06c09ec5703b8b158 SHA512 8abfe3a70ae0758a001274b07523647cdf0f4e760eb98867577b1ac6306bbebd0f8ddee93de2782da2a19b9476e120e571b4638c07b93ffbfc060822d4ff126f
+DIST yt-dlp-2024.07.16.tar.gz 5688157 BLAKE2B a1e4cd8ff7b73246aed2239298d548945c99fe8d76d41b9e3293767b7b680028f4d23f2fc116516e853be163b267a600f99525784d9b3cc16280f1b8b2d5a90a SHA512 17f5aa71ae01b6a009e5b0a4380d9329530563ee01ac268a2a6acff01732ce0c9d14181790a15b182b0de09a35b6db2f3e814acc50934d5f3e361245027926e9
diff --git a/net-misc/yt-dlp/yt-dlp-2024.07.16.ebuild b/net-misc/yt-dlp/yt-dlp-2024.07.16.ebuild
new file mode 100644
index 000000000000..68214ba4c2eb
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2024.07.16.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust pycryptodome and drop optional dependencies (bug #828466)
+ sed -Ei pyproject.toml \
+ -e 's/("pycryptodome)x/\1/' \
+ -e '/"(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d' || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=network-sandbox
+ test/test_networking.py::TestHTTPRequestHandler::test_connect_timeout
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}