summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-04-15 16:26:08 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-04-15 16:41:24 -0400
commitc4b563257db1df0dd674b7700a7c400b1a83756e (patch)
tree6883d41900f6ec0620b8bed4162186efb2ba236c /net-misc
parentapp-text/mdbook: add 0.4.18 (diff)
downloadgentoo-c4b563257db1df0dd674b7700a7c400b1a83756e.tar.gz
gentoo-c4b563257db1df0dd674b7700a7c400b1a83756e.tar.bz2
gentoo-c4b563257db1df0dd674b7700a7c400b1a83756e.zip
net-misc/ytfzf: add 2.3
Also replace postinst upgrade elog by a generic dependency warning. ytfzf has addons/methods which can add a lot of misc dependencies while having more niche use-cases (e.g. only for sway, or only with kitty terminal). Users of these should already have necessary dependencies and adding more optfeatures doesn't seem necessary. As for old warning, <2.0 barely existed in-tree and there's no need to keep it forever. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ytfzf/Manifest1
-rw-r--r--net-misc/ytfzf/ytfzf-2.3.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-misc/ytfzf/Manifest b/net-misc/ytfzf/Manifest
index 76d90ffa86df..356440f2ad54 100644
--- a/net-misc/ytfzf/Manifest
+++ b/net-misc/ytfzf/Manifest
@@ -1 +1,2 @@
DIST ytfzf-2.2.tar.gz 3242266 BLAKE2B 7bc6317ea2ee67ca1d93acc5262d5ebc7f6c9828531f1b97d1fd8e4cfb9e9328cf9955da993d59dcfe05a1a983106cf98f3c93ab4b2c007458154f860e333b55 SHA512 9f47da0e56d096d248b14387c3e34f11cc101fa958945e17bdee83d81c2da57faf384fe87d46132e4cc78a5f4f6057462e28c1a64ea647a98120c37ed4e7f50d
+DIST ytfzf-2.3.tar.gz 3249215 BLAKE2B 963442379ea324aa6f7b4077df417815ec1e1822d1598029efd397e2a29996ae92aa2f18e67ec6f7fea16a5804d3a7875cec625be1f5f49eb35c85dc84f3a894 SHA512 a282f578459ec53e725d1089a5b5efb78dcc66684ce572d0318f6bfd6e222b706418c77eeeca34d4015ed2bae1cb54de10edaab36522d6012c2ac421796ef34b
diff --git a/net-misc/ytfzf/ytfzf-2.3.ebuild b/net-misc/ytfzf/ytfzf-2.3.ebuild
new file mode 100644
index 000000000000..aabfab731b1b
--- /dev/null
+++ b/net-misc/ytfzf/ytfzf-2.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Posix script to find and watch youtube videos from the terminal"
+HOMEPAGE="https://github.com/pystardust/ytfzf/"
+SRC_URI="https://github.com/pystardust/ytfzf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+# fzf/mpv/yt-dlp "can" be optfeatures depending on configuration, but depend
+# on them so it works as expected out-of-the-box while allowing to disable.
+RDEPEND="
+ app-misc/jq
+ net-misc/curl[ssl]
+ virtual/awk
+ !minimal? (
+ app-shells/fzf
+ media-video/mpv[lua]
+ net-misc/yt-dlp
+ )"
+
+src_prepare() {
+ default
+
+ sed -i "/^: ...YTFZF_SYSTEM_ADDON_DIR/s|/usr/local|${EPREFIX}/usr|" ytfzf || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ emake "${emakeargs[@]}" addons doc install
+ einstalldocs
+
+ rm -r "${ED}"/usr/share/licenses || die
+}
+
+pkg_postinst() {
+ optfeature "external menu support" x11-misc/dmenu
+ optfeature "in-terminal thumbnails on X11" media-gfx/ueberzug
+ optfeature "desktop notifications" x11-libs/libnotify
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Note that ${PN} supports many methods to display menus/thumbnails."
+ elog "This ebuild primarily covers defaults and major features, additional"
+ elog "dependencies may be needed for others."
+ fi
+}