summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2019-10-03 11:17:37 -0500
committerBen Kohler <bkohler@gentoo.org>2019-10-03 11:18:00 -0500
commitb0ed85eec3c8e5eb14e86fbe037d914896679a4a (patch)
tree15d93037544cb9de7bdabdfd822d6d6885341182 /net-misc
parentdev-libs/rocr-runtime: Fix SIGSEGV (diff)
downloadgentoo-b0ed85eec3c8e5eb14e86fbe037d914896679a4a.tar.gz
gentoo-b0ed85eec3c8e5eb14e86fbe037d914896679a4a.tar.bz2
gentoo-b0ed85eec3c8e5eb14e86fbe037d914896679a4a.zip
net-misc/connman-notify: add patch for python3 compat, update deps
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild38
-rw-r--r--net-misc/connman-notify/files/connman-notify-py3-support.patch38
2 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild b/net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild
new file mode 100644
index 000000000000..f3fa6cd20fef
--- /dev/null
+++ b/net-misc/connman-notify/connman-notify-0_pre20140623-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7} )
+
+inherit desktop python-single-r1 vcs-snapshot
+
+MY_COMMIT="0ed9b5e4a0e1f03c83c4589cabf410cac66cd11d"
+
+DESCRIPTION="Desktop notification integration for connman"
+HOMEPAGE="https://gitlab.com/wavexx/connman-notify/"
+SRC_URI="https://gitlab.com/wavexx/connman-notify/repository/${MY_COMMIT}/archive.tar.bz2 -> ${P}.tar.bz2"
+
+EGIT_REPO_URI="https://gitlab.com/wavexx/connman-notify.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-misc/connman
+ virtual/notification-daemon"
+
+PATCHES=( "${FILESDIR}"/connman-notify-py3-support.patch )
+
+src_install() {
+ python_fix_shebang ${PN}
+ dobin ${PN}
+ dodoc README.rst
+
+ make_desktop_entry ${PN} ${PN} ${PN} Network
+}
diff --git a/net-misc/connman-notify/files/connman-notify-py3-support.patch b/net-misc/connman-notify/files/connman-notify-py3-support.patch
new file mode 100644
index 000000000000..59c888495560
--- /dev/null
+++ b/net-misc/connman-notify/files/connman-notify-py3-support.patch
@@ -0,0 +1,38 @@
+--- a/connman-notify
++++ b/connman-notify
+@@ -7,8 +7,8 @@
+ import argparse
+ import dbus
+ import dbus.mainloop.glib
+-import glib
+-import pynotify
++from gi.repository import GLib
++from gi.repository import Notify
+
+ APP_NAME = 'connman'
+ SHORT_DEV = True
+@@ -22,7 +22,7 @@
+
+
+ def notify(subject, body):
+- ntf = pynotify.Notification(subject, body)
++ ntf = Notify.Notification.new(subject, body)
+ ntf.show()
+
+
+@@ -79,7 +79,7 @@
+ if args.hide_addr: SHOW_ADDR = False
+
+ dbus.mainloop.glib.DBusGMainLoop(set_as_default=True)
+- pynotify.init(APP_NAME)
++ Notify.init(APP_NAME)
+ bus = dbus.SystemBus()
+ manager = dbus.Interface(bus.get_object("net.connman", "/"), "net.connman.Manager")
+
+@@ -88,5 +88,5 @@
+ signal_name="PropertyChanged",
+ path_keyword="path")
+
+- mainloop = glib.MainLoop()
++ mainloop = GLib.MainLoop()
+ mainloop.run()