summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-15 23:53:56 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-16 00:00:17 +0100
commit5f06fce745e532ed5afd015944a3d5177e0cf2f2 (patch)
tree8a2bc8107679fa1b8b5eee8344d7496b6f072481 /net-misc
parentwww-misc/surl: EAPI 6 bump. (diff)
downloadgentoo-5f06fce745e532ed5afd015944a3d5177e0cf2f2.tar.gz
gentoo-5f06fce745e532ed5afd015944a3d5177e0cf2f2.tar.bz2
gentoo-5f06fce745e532ed5afd015944a3d5177e0cf2f2.zip
net-misc/raccess: removal.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/raccess/Manifest1
-rw-r--r--net-misc/raccess/files/raccess-0.7-glibc210.patch585
-rw-r--r--net-misc/raccess/files/raccess-0.7-r1-asneeded.patch11
-rw-r--r--net-misc/raccess/metadata.xml5
-rw-r--r--net-misc/raccess/raccess-0.7.ebuild36
5 files changed, 0 insertions, 638 deletions
diff --git a/net-misc/raccess/Manifest b/net-misc/raccess/Manifest
deleted file mode 100644
index 09aeee846c0b..000000000000
--- a/net-misc/raccess/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST raccess-0.7.tar.gz 228067 SHA256 df48138333e674aea7b76f00ca67fccae74af9972ddd421c1c959ea2aaa34a50 SHA512 610c0d4cebf5130eb2de4b64e76ff55210645331ce8a24b6a3e6975f456b6f447e737a59634a052e5bacf74cb300b6ef02d95a5ab133d2af5f7e239ee006675d WHIRLPOOL e0b95536c2204fedfc6a2b73ef2fb4c496487ba7f96c4f58e269d4218f8b746e7f36bc01d8dcfb2397e5b38402d29015fa293df316786cbe2646e42cb6c1ba18
diff --git a/net-misc/raccess/files/raccess-0.7-glibc210.patch b/net-misc/raccess/files/raccess-0.7-glibc210.patch
deleted file mode 100644
index 2ffb5660ed2e..000000000000
--- a/net-misc/raccess/files/raccess-0.7-glibc210.patch
+++ /dev/null
@@ -1,585 +0,0 @@
-diff -NrU5 raccess-0.7.original/exploits/wu2.5.0a.c raccess-0.7/exploits/wu2.5.0a.c
---- raccess-0.7.original/exploits/wu2.5.0a.c 2009-07-08 17:55:35.000000000 +0000
-+++ raccess-0.7/exploits/wu2.5.0a.c 2009-07-08 18:09:23.000000000 +0000
-@@ -104,11 +104,11 @@
- int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
- void sighandler (int signal);
- struct hostent *xgethostbyname (const char *name);
- struct hostent *xgethostbyaddr (const char *addr, int len, int type);
- void putserv (const char *fmt, ...);
--char *getline (void);
-+char *get_line (void);
- char *getmsg (const char *msg);
- int wuftpd_250_sploitit (void);
- dirptr newdir (char *name);
- char *getdir (char *stat);
- char *int2char (int addr);
-@@ -759,16 +759,16 @@
- }
-
- #define LINEBUFLEN 8192
- char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
-
--/* getline
-+/* get_line
- *
- * get next line from server or local buffer
- */
- char *
--getline (void)
-+get_line (void)
- {
- char y[2];
- int i = 0;
-
- memset (linebuf, '\0', sizeof (linebuf));
-@@ -776,11 +776,11 @@
-
- while (strncmp (y, "\n", 1) != 0)
- {
- if (i > (sizeof (linebuf) + 2))
- {
-- err (0, "getline() buffer full");
-+ err (0, "get_line() buffer full");
- }
- i += xread (fd, y, 1);
- strcat (linebuf, y);
- }
-
-@@ -835,11 +835,11 @@
- char *line;
- int i = strlen (msg);
-
- do
- {
-- line = getline ();
-+ line = get_line ();
- }
- while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
-
- return (line);
- }
-@@ -919,11 +919,11 @@
- nostat = 0;
- putserv ("STAT .\n");
-
- while (strncmp (line, "213 ", 4) != 0)
- {
-- line = getline ();
-+ line = get_line ();
- tmp = getdir (line);
-
- if (tmp == NULL)
- continue;
- if (dirroot == NULL)
-@@ -1279,14 +1279,14 @@
- break;
- }
-
- string[tesopt.dirlen] = 0;
- putserv ("MKD %s\n", string);
-- getline ();
-+ get_line ();
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
- }
-
- getpwd ();
- disp = 1;
-
-@@ -1318,11 +1318,11 @@
-
- if (strlen (string) < 20)
- err (0, "cwd string too short.. check for 0x0's.\n");
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
-
- /************ jmpbuf ***********/
-
- if (debug > 0)
- printf ("Sending jmpbuf\n");
-@@ -1334,11 +1334,11 @@
- if (strlen (string) != 32)
- err (0, "jmpbuf string too short.. check for 0x0's.\n");
-
- putserv ("%s\n", string);
-
-- getline ();
-+ get_line ();
-
- return (1);
- }
-
- /* shell
-diff -NrU5 raccess-0.7.original/exploits/wu2.5.0b.c raccess-0.7/exploits/wu2.5.0b.c
---- raccess-0.7.original/exploits/wu2.5.0b.c 2009-07-08 17:55:35.000000000 +0000
-+++ raccess-0.7/exploits/wu2.5.0b.c 2009-07-08 18:12:44.000000000 +0000
-@@ -104,11 +104,11 @@
- int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
- void sighandler (int signal);
- struct hostent *xgethostbyname (const char *name);
- struct hostent *xgethostbyaddr (const char *addr, int len, int type);
- void putserv (const char *fmt, ...);
--char *getline (void);
-+char *get_line (void);
- char *getmsg (const char *msg);
- int wuftpd_250_sploitit (void);
- dirptr newdir (char *name);
- char *getdir (char *stat);
- char *int2char (int addr);
-@@ -759,16 +759,16 @@
- }
-
- #define LINEBUFLEN 8192
- char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
-
--/* getline
-+/* get_line
- *
- * get next line from server or local buffer
- */
- char *
--getline (void)
-+get_line (void)
- {
- char y[2];
- int i = 0;
-
- memset (linebuf, '\0', sizeof (linebuf));
-@@ -776,11 +776,11 @@
-
- while (strncmp (y, "\n", 1) != 0)
- {
- if (i > (sizeof (linebuf) + 2))
- {
-- err (0, "getline() buffer full");
-+ err (0, "get_line() buffer full");
- }
- i += xread (fd, y, 1);
- strcat (linebuf, y);
- }
-
-@@ -835,11 +835,11 @@
- char *line;
- int i = strlen (msg);
-
- do
- {
-- line = getline ();
-+ line = get_line ();
- }
- while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
-
- return (line);
- }
-@@ -919,11 +919,11 @@
- nostat = 0;
- putserv ("STAT .\n");
-
- while (strncmp (line, "213 ", 4) != 0)
- {
-- line = getline ();
-+ line = get_line ();
- tmp = getdir (line);
-
- if (tmp == NULL)
- continue;
- if (dirroot == NULL)
-@@ -1279,14 +1279,14 @@
- break;
- }
-
- string[tesopt.dirlen] = 0;
- putserv ("MKD %s\n", string);
-- getline ();
-+ get_line ();
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
- }
-
- getpwd ();
- disp = 1;
-
-@@ -1318,11 +1318,11 @@
-
- if (strlen (string) < 20)
- err (0, "cwd string too short.. check for 0x0's.\n");
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
-
- /************ jmpbuf ***********/
-
- if (debug > 0)
- printf ("Sending jmpbuf\n");
-@@ -1334,11 +1334,11 @@
- if (strlen (string) != 32)
- err (0, "jmpbuf string too short.. check for 0x0's.\n");
-
- putserv ("%s\n", string);
-
-- getline ();
-+ get_line ();
-
- return (1);
- }
-
- /* shell
-diff -NrU5 raccess-0.7.original/exploits/wu2.5.0c.c raccess-0.7/exploits/wu2.5.0c.c
---- raccess-0.7.original/exploits/wu2.5.0c.c 2009-07-08 17:55:35.000000000 +0000
-+++ raccess-0.7/exploits/wu2.5.0c.c 2009-07-08 18:14:14.000000000 +0000
-@@ -104,11 +104,11 @@
- int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
- void sighandler (int signal);
- struct hostent *xgethostbyname (const char *name);
- struct hostent *xgethostbyaddr (const char *addr, int len, int type);
- void putserv (const char *fmt, ...);
--char *getline (void);
-+char *get_line (void);
- char *getmsg (const char *msg);
- int wuftpd_250_sploitit (void);
- dirptr newdir (char *name);
- char *getdir (char *stat);
- char *int2char (int addr);
-@@ -759,16 +759,16 @@
- }
-
- #define LINEBUFLEN 8192
- char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
-
--/* getline
-+/* get_line
- *
- * get next line from server or local buffer
- */
- char *
--getline (void)
-+get_line (void)
- {
- char y[2];
- int i = 0;
-
- memset (linebuf, '\0', sizeof (linebuf));
-@@ -776,11 +776,11 @@
-
- while (strncmp (y, "\n", 1) != 0)
- {
- if (i > (sizeof (linebuf) + 2))
- {
-- err (0, "getline() buffer full");
-+ err (0, "get_line() buffer full");
- }
- i += xread (fd, y, 1);
- strcat (linebuf, y);
- }
-
-@@ -835,11 +835,11 @@
- char *line;
- int i = strlen (msg);
-
- do
- {
-- line = getline ();
-+ line = get_line ();
- }
- while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
-
- return (line);
- }
-@@ -919,11 +919,11 @@
- nostat = 0;
- putserv ("STAT .\n");
-
- while (strncmp (line, "213 ", 4) != 0)
- {
-- line = getline ();
-+ line = get_line ();
- tmp = getdir (line);
-
- if (tmp == NULL)
- continue;
- if (dirroot == NULL)
-@@ -1279,14 +1279,14 @@
- break;
- }
-
- string[tesopt.dirlen] = 0;
- putserv ("MKD %s\n", string);
-- getline ();
-+ get_line ();
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
- }
-
- getpwd ();
- disp = 1;
-
-@@ -1318,11 +1318,11 @@
-
- if (strlen (string) < 20)
- err (0, "cwd string too short.. check for 0x0's.\n");
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
-
- /************ jmpbuf ***********/
-
- if (debug > 0)
- printf ("Sending jmpbuf\n");
-@@ -1334,11 +1334,11 @@
- if (strlen (string) != 32)
- err (0, "jmpbuf string too short.. check for 0x0's.\n");
-
- putserv ("%s\n", string);
-
-- getline ();
-+ get_line ();
-
- return (1);
- }
-
- /* shell
-diff -NrU5 raccess-0.7.original/exploits/wu2.5.0d.c raccess-0.7/exploits/wu2.5.0d.c
---- raccess-0.7.original/exploits/wu2.5.0d.c 2009-07-08 17:55:35.000000000 +0000
-+++ raccess-0.7/exploits/wu2.5.0d.c 2009-07-08 18:06:24.000000000 +0000
-@@ -104,11 +104,11 @@
- int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
- void sighandler (int signal);
- struct hostent *xgethostbyname (const char *name);
- struct hostent *xgethostbyaddr (const char *addr, int len, int type);
- void putserv (const char *fmt, ...);
--char *getline (void);
-+char *get_line (void);
- char *getmsg (const char *msg);
- int wuftpd_250_sploitit (void);
- dirptr newdir (char *name);
- char *getdir (char *stat);
- char *int2char (int addr);
-@@ -759,16 +759,16 @@
- }
-
- #define LINEBUFLEN 8192
- char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
-
--/* getline
-+/* get_line
- *
- * get next line from server or local buffer
- */
- char *
--getline (void)
-+get_line (void)
- {
- char y[2];
- int i = 0;
-
- memset (linebuf, '\0', sizeof (linebuf));
-@@ -776,11 +776,11 @@
-
- while (strncmp (y, "\n", 1) != 0)
- {
- if (i > (sizeof (linebuf) + 2))
- {
-- err (0, "getline() buffer full");
-+ err (0, "get_line() buffer full");
- }
- i += xread (fd, y, 1);
- strcat (linebuf, y);
- }
-
-@@ -835,11 +835,11 @@
- char *line;
- int i = strlen (msg);
-
- do
- {
-- line = getline ();
-+ line = get_line ();
- }
- while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
-
- return (line);
- }
-@@ -919,11 +919,11 @@
- nostat = 0;
- putserv ("STAT .\n");
-
- while (strncmp (line, "213 ", 4) != 0)
- {
-- line = getline ();
-+ line = get_line ();
- tmp = getdir (line);
-
- if (tmp == NULL)
- continue;
- if (dirroot == NULL)
-@@ -1279,14 +1279,14 @@
- break;
- }
-
- string[tesopt.dirlen] = 0;
- putserv ("MKD %s\n", string);
-- getline ();
-+ get_line ();
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
- }
-
- getpwd ();
- disp = 1;
-
-@@ -1318,11 +1318,11 @@
-
- if (strlen (string) < 20)
- err (0, "cwd string too short.. check for 0x0's.\n");
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
-
- /************ jmpbuf ***********/
-
- if (debug > 0)
- printf ("Sending jmpbuf\n");
-@@ -1334,11 +1334,11 @@
- if (strlen (string) != 32)
- err (0, "jmpbuf string too short.. check for 0x0's.\n");
-
- putserv ("%s\n", string);
-
-- getline ();
-+ get_line ();
-
- return (1);
- }
-
- /* shell
-diff -NrU5 raccess-0.7.original/exploits/wu2.5.0e.c raccess-0.7/exploits/wu2.5.0e.c
---- raccess-0.7.original/exploits/wu2.5.0e.c 2009-07-08 17:55:35.000000000 +0000
-+++ raccess-0.7/exploits/wu2.5.0e.c 2009-07-08 18:07:19.000000000 +0000
-@@ -104,11 +104,11 @@
- int xconnect (int sockfd, struct sockaddr *serv_addr, int addrlen);
- void sighandler (int signal);
- struct hostent *xgethostbyname (const char *name);
- struct hostent *xgethostbyaddr (const char *addr, int len, int type);
- void putserv (const char *fmt, ...);
--char *getline (void);
-+char *get_line (void);
- char *getmsg (const char *msg);
- int wuftpd_250_sploitit (void);
- dirptr newdir (char *name);
- char *getdir (char *stat);
- char *int2char (int addr);
-@@ -759,16 +759,16 @@
- }
-
- #define LINEBUFLEN 8192
- char linebuf[LINEBUFLEN]; /* saves us free()ing trouble. */
-
--/* getline
-+/* get_line
- *
- * get next line from server or local buffer
- */
- char *
--getline (void)
-+get_line (void)
- {
- char y[2];
- int i = 0;
-
- memset (linebuf, '\0', sizeof (linebuf));
-@@ -776,11 +776,11 @@
-
- while (strncmp (y, "\n", 1) != 0)
- {
- if (i > (sizeof (linebuf) + 2))
- {
-- err (0, "getline() buffer full");
-+ err (0, "get_line() buffer full");
- }
- i += xread (fd, y, 1);
- strcat (linebuf, y);
- }
-
-@@ -835,11 +835,11 @@
- char *line;
- int i = strlen (msg);
-
- do
- {
-- line = getline ();
-+ line = get_line ();
- }
- while (strncmp (line, msg, i) != 0 && strncmp (line, "5", 1) != 0);
-
- return (line);
- }
-@@ -919,11 +919,11 @@
- nostat = 0;
- putserv ("STAT .\n");
-
- while (strncmp (line, "213 ", 4) != 0)
- {
-- line = getline ();
-+ line = get_line ();
- tmp = getdir (line);
-
- if (tmp == NULL)
- continue;
- if (dirroot == NULL)
-@@ -1279,14 +1279,14 @@
- break;
- }
-
- string[tesopt.dirlen] = 0;
- putserv ("MKD %s\n", string);
-- getline ();
-+ get_line ();
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
- }
-
- getpwd ();
- disp = 1;
-
-@@ -1318,11 +1318,11 @@
-
- if (strlen (string) < 20)
- err (0, "cwd string too short.. check for 0x0's.\n");
-
- putserv ("CWD %s\n", string);
-- getline ();
-+ get_line ();
-
- /************ jmpbuf ***********/
-
- if (debug > 0)
- printf ("Sending jmpbuf\n");
-@@ -1334,11 +1334,11 @@
- if (strlen (string) != 32)
- err (0, "jmpbuf string too short.. check for 0x0's.\n");
-
- putserv ("%s\n", string);
-
-- getline ();
-+ get_line ();
-
- return (1);
- }
-
- /* shell
diff --git a/net-misc/raccess/files/raccess-0.7-r1-asneeded.patch b/net-misc/raccess/files/raccess-0.7-r1-asneeded.patch
deleted file mode 100644
index 47ed0e1aa35b..000000000000
--- a/net-misc/raccess/files/raccess-0.7-r1-asneeded.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2009-01-05 19:23:26.671861574 +0100
-+++ src/Makefile.in 2009-01-05 19:23:37.603959062 +0100
-@@ -83,7 +83,7 @@
- detectos.o remote_attack_module.o lookfor.o
- raccess_LDADD = $(LDADD)
- raccess_DEPENDENCIES =
--raccess_LDFLAGS = -lm
-+raccess_LDADD = -lm
- BINFILES = -DLOCATION_BIN_FILES=\"@bindir@\"
- CFGFILES = -DLOCATION_CONFIG_FILES=\"@sysconfdir@\"
- COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(BINFILES) $(CFGFILES)
diff --git a/net-misc/raccess/metadata.xml b/net-misc/raccess/metadata.xml
deleted file mode 100644
index 6f49eba8f496..000000000000
--- a/net-misc/raccess/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<!-- maintainer-needed -->
-</pkgmetadata>
diff --git a/net-misc/raccess/raccess-0.7.ebuild b/net-misc/raccess/raccess-0.7.ebuild
deleted file mode 100644
index 82f90fad20f6..000000000000
--- a/net-misc/raccess/raccess-0.7.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="Remote Access Session is an systems security analyzer"
-HOMEPAGE="http://salix.org/raccess/"
-SRC_URI="http://salix.org/raccess/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 sparc ~ppc ~amd64"
-IUSE=""
-
-DEPEND="net-libs/libpcap"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-r1-asneeded.patch
- epatch "${FILESDIR}"/${P}-glibc210.patch
- sed -i '/^BINFILES/s:@bindir@:/usr/$(get_libdir)/raccess:' src/Makefile.in
- sed -i '/^bindir/s:@bindir@/exploits:/usr/$(get_libdir)/raccess:' exploits/Makefile.in
-}
-
-src_compile() {
- econf --sysconfdir=/etc/raccess
- emake CC="$(tc-getCC)" || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS PROJECT_PLANNING README
-}