summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-04-24 08:24:03 -0300
committerMatt Turner <mattst88@gentoo.org>2023-04-24 12:41:41 -0400
commit09f62296266f6d74c54477e1a2e653d3659e71c4 (patch)
tree6290d5d1cf86afaf4da986211dbb0d8b4377f275 /net-misc
parentgnome-extra/gnome-shell-frippery: Version bump to 44.0 (diff)
downloadgentoo-09f62296266f6d74c54477e1a2e653d3659e71c4.tar.gz
gentoo-09f62296266f6d74c54477e1a2e653d3659e71c4.tar.bz2
gentoo-09f62296266f6d74c54477e1a2e653d3659e71c4.zip
net-misc/gnome-connections: Version bump to 44.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30729 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gnome-connections/Manifest1
-rw-r--r--net-misc/gnome-connections/gnome-connections-44.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-misc/gnome-connections/Manifest b/net-misc/gnome-connections/Manifest
index d40292e03737..95f6f47c3ca8 100644
--- a/net-misc/gnome-connections/Manifest
+++ b/net-misc/gnome-connections/Manifest
@@ -1 +1,2 @@
DIST gnome-connections-44.0.tar.xz 3998876 BLAKE2B 062769eafddb52da9962a59c11697205a0370d890425488a29d1bec2d4f2ba62041ff7d271d9bc7aae1a4fe108fa617864eea63755a6c02de07b340329dd2e5c SHA512 8193877175e5d553ada0b0c7985ee2029c85d0cb2fde16d5a47b9c6c0027deb22c4d1c8f4b2188ab430f3702318b2c1a229b0297a1e90aea45697e733733b3e9
+DIST gnome-connections-44.1.tar.xz 3999000 BLAKE2B 62f811a5cf530d3b38b576217d004d982f051a12bd3e525499d7fa4466538a1c8a2d4713f15cb0862d753f06a1f624f8fa87b80498ecbb461e7e7a545cb8c4d5 SHA512 34878e51ae67b222f8c5a00524bf2f3f24b9bc989ceccd707028ecdec612d81d3dc5e187e000f6e870e1cf816a66342cb8e9e9aaf7a6296950e1efa5b8a0d47e
diff --git a/net-misc/gnome-connections/gnome-connections-44.1.ebuild b/net-misc/gnome-connections/gnome-connections-44.1.ebuild
new file mode 100644
index 000000000000..325726aeadc2
--- /dev/null
+++ b/net-misc/gnome-connections/gnome-connections-44.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A remote desktop client for the GNOME desktop environment"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/connections"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/gobject-introspection
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=net-libs/gtk-vnc-0.4.4[pulseaudio,vala]
+ >=gui-libs/libhandy-1.6.0:1[vala]
+ >=dev-libs/libxml2-2.7.8
+ app-crypt/libsecret[vala]
+
+ >=net-misc/freerdp-2.0.0:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/glib
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}